summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-01-24 21:38:21 +0100
committerMart Raudsepp <leio@gentoo.org>2024-04-01 22:53:29 +0300
commit5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d (patch)
treecdd57168efdd0079ba10a506ef883bffc6eec65f /media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.10.ebuild
parentdev-util/ruff: new package, add 0.3.5 (diff)
downloadgentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.tar.gz
gentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.tar.bz2
gentoo-5b6f9eaa395da5ca7a95d7ba47db133035e8ea7d.zip
media-libs/gstreamer: add 1.22.10, drop 1.22.3 (security)
- eclass / gst-plugins-good: Add "soup" option in the special cases - gst-plugins-good: Backport fix against tests being enabled on libsoup presence automagic-style <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/6058> Closes: https://bugs.gentoo.org/836163 Closes: https://bugs.gentoo.org/908978 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.10.ebuild')
-rw-r--r--media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.10.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.10.ebuild b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.10.ebuild
new file mode 100644
index 000000000000..f12248d2c7b6
--- /dev/null
+++ b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.22.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="HTTP live streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/gst-plugins-bad-1.18.4-use-system-libs-hls.patch
+)
+
+src_prepare() {
+ default
+ gstreamer_system_library gstadaptivedemux_dep:gstadaptivedemux
+ gstreamer_system_package pbutils_dep:gstreamer-pbutils
+ gstreamer_system_package tag_dep:gstreamer-tag
+ gstreamer_system_package video_dep:gstreamer-video
+ gstreamer_system_library gsturidownloader_dep:gsturidownloader
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dhls-crypto=nettle
+ )
+
+ gstreamer_multilib_src_configure
+}