summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-02-19 12:49:30 +0300
committerSam James <sam@gentoo.org>2022-03-08 13:32:19 +0000
commit93b6417f1b55aefc05b91fec7b67eadd32b1f733 (patch)
tree2aa4e2a88378a5d76295ee10fc7b91f2ac40c259 /media-plugins/gst-plugins-libav
parentmedia-libs/libfreeaptx: Change to multilib build (diff)
downloadgentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.gz
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.bz2
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.zip
media-libs/gstreamer: Bump to 1.20.0
Gstreamer 1.20.0 version bump, includes - all existing 1.18.4 plugins except for two dropped upstream (gst-plugins-libmms and gst-plugins-ofa) - libnice-0.1.18 version bump required by gst-plugins-webrtc in 1.20.0 - required multilib change for libldac for new plugin gst-plugins-ldac - required multilib change for libopenaptx and libfreeaptx for new plugin gst-plugins-openaptx As discussed, this change adds a LICENSE to each of gstreamer modules which now require explicit opt-in for (A)GPL plugins for (A)GPL plugins we will not perform explicit license acceptance for affected gstreamer plugin, instead we will rely on a user accepting the license of dependency: - gstreamer change added explicit opt-in https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1084 - I looked at affected gstreamer plugins and looks like all are correctly license-compatible according to compatibility matrix https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility - if a user is not willing to accept the license of corresponding (A)GPL dependency, such dependency will not be available and affected gstreamer plugin will not be built - Upstream gstreamer team will look into updating/fixing plugin license display available via gst-inspect-1.0 <plugin name> | grep License as currently it is just "GPL" which is not specific enough (should be GPL-2, GPL-2+, GPL-3 etc.) Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-libav')
-rw-r--r--media-plugins/gst-plugins-libav/Manifest1
-rw-r--r--media-plugins/gst-plugins-libav/gst-plugins-libav-1.20.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-libav/Manifest b/media-plugins/gst-plugins-libav/Manifest
index ecd02614acad..b9e661fe2e54 100644
--- a/media-plugins/gst-plugins-libav/Manifest
+++ b/media-plugins/gst-plugins-libav/Manifest
@@ -1,2 +1,3 @@
DIST gst-libav-1.16.3.tar.xz 9472760 BLAKE2B 3e98381244d74aa695c737a898711b311518749c6f949af7bd03d08cdf383cbe1a78cea8e3f0268fdb2132bec930803f8fa31e919c6c268b6f8d58092f01fd04 SHA512 37fe621a8d45ac6bf51383a776f3091cc114faaf84b0097e86f33eb4e8c0b70b4cc6fa467aad63daca9b1b24db24c10a067c973ef8232c2965eedeba3d251b0b
DIST gst-libav-1.18.4.tar.xz 281576 BLAKE2B 5ce7b15163a0671744ca6920865b2e3be35ac9209f8b3b0e73202684fe4da2e16abdee2be2d3844170cd688b58b3eadf89b3f3b87b457dc939ae409fe42bc410 SHA512 4eb10af6698f724bbc8d5b7b215e7349e6ff3b52e24b3987ee4077db1ae27ae0d6f25309adc50f0fccdf5af4d617634a7339ad1e5466a737c40a25c52c0d023f
+DIST gst-libav-1.20.0.tar.xz 277816 BLAKE2B 7e18e73ceeb67668ff8e327639fca235a261057061017e97064423c2dfe913690f44c935ff6e68d5c754f009cb9ffe76b2a4276c2b139943be71db6f93271999 SHA512 51cedfc3489915507d7640220aafe4f71ef3bbe5e7de9aa18187f211275a29917a893ee0375a89f256bda6c63e5103e1c4614f3e236ffe46e550ce518c9e7109
diff --git a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.20.0.ebuild b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.20.0.ebuild
new file mode 100644
index 000000000000..c02b45c4787a
--- /dev/null
+++ b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.20.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson
+
+MY_PN="gst-libav"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${MY_PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${MY_PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-video/ffmpeg-4:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"