summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-05-04 20:51:42 +0300
committerMart Raudsepp <leio@gentoo.org>2020-05-04 20:52:41 +0300
commitb3e407128c281905db419a55efbfb19c5fdccb73 (patch)
tree0d9b5b93e916dbbbed1ecd47bf3771ae3c4c6a3f /media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.16.2-r1.ebuild
parentFixed CPE tag for sys-process/tini (diff)
downloadgentoo-b3e407128c281905db419a55efbfb19c5fdccb73.tar.gz
gentoo-b3e407128c281905db419a55efbfb19c5fdccb73.tar.bz2
gentoo-b3e407128c281905db419a55efbfb19c5fdccb73.zip
media-plugins/gst-plugins-opencv: raise opencv minimum to ensure testing
opencv3 is going away soon; raise minimum to ensure it gets tested more against opencv4. Also change contrib(+) USE dep to contrib, as the IUSE not existing was a opencv2 thing. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.16.2-r1.ebuild')
-rw-r--r--media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.16.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.16.2-r1.ebuild b/media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.16.2-r1.ebuild
new file mode 100644
index 000000000000..6e31c6ff5ec5
--- /dev/null
+++ b/media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.16.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="OpenCV elements for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# >=opencv-4.1.2-r3 to help testing removal of older being fine
+RDEPEND="
+ >=media-libs/opencv-4.1.2-r3:=[contrib,${MULTILIB_USEDEP}]
+ <media-libs/opencv-4.2
+"
+DEPEND="${RDEPEND}"
+
+# Ships the opencv separate helper library as part of gst-plugins-opencv as it depends on OpenCV
+multilib_src_compile() {
+ emake -C gst-libs/gst/opencv
+ gstreamer_multilib_src_compile
+}
+
+multilib_src_install() {
+ emake -C gst-libs/gst/opencv DESTDIR="${D}" install
+ gstreamer_multilib_src_install
+}