summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-06-18 10:33:22 +0300
committerMart Raudsepp <leio@gentoo.org>2017-06-18 11:30:40 +0300
commit257e1104cce39c4b750526e43e444d0ec9763ec3 (patch)
tree71972df0b7b0d8a59350fd0573f627e1a406ccde /media-plugins/gst-plugins-uvch264/gst-plugins-uvch264-1.10.5.ebuild
parentmedia-plugins/gst-plugins-srtp: bump to 1.10.5, no code changes compared to 1... (diff)
downloadgentoo-257e1104cce39c4b750526e43e444d0ec9763ec3.tar.gz
gentoo-257e1104cce39c4b750526e43e444d0ec9763ec3.tar.bz2
gentoo-257e1104cce39c4b750526e43e444d0ec9763ec3.zip
media-plugins/gst-plugins-uvch264: bump to 1.10.5, no code changes compared to 1.10.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-plugins/gst-plugins-uvch264/gst-plugins-uvch264-1.10.5.ebuild')
-rw-r--r--media-plugins/gst-plugins-uvch264/gst-plugins-uvch264-1.10.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-uvch264/gst-plugins-uvch264-1.10.5.ebuild b/media-plugins/gst-plugins-uvch264/gst-plugins-uvch264-1.10.5.ebuild
new file mode 100644
index 000000000000..7faf6af2b96f
--- /dev/null
+++ b/media-plugins/gst-plugins-uvch264/gst-plugins-uvch264-1.10.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="UVC compliant H264 encoding cameras plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libgudev:=[${MULTILIB_USEDEP}]
+ virtual/libusb:1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gstbasecamerabin does not have a .pc
+ # gstreamer_system_link \
+ # gst-libs/gst/basecamerabinsrc:gstbasecamerabinsrc
+
+ local directory libs
+ directory="gst-libs/gst/basecamerabinsrc"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgstapp-1.0 -lgstbasecamerabinsrc-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i sys/uvch264/Makefile.{am,in} || die
+}