summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-02-19 12:49:30 +0300
committerSam James <sam@gentoo.org>2022-03-08 13:32:19 +0000
commit93b6417f1b55aefc05b91fec7b67eadd32b1f733 (patch)
tree2aa4e2a88378a5d76295ee10fc7b91f2ac40c259 /media-plugins/gst-plugins-x265
parentmedia-libs/libfreeaptx: Change to multilib build (diff)
downloadgentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.gz
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.bz2
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.zip
media-libs/gstreamer: Bump to 1.20.0
Gstreamer 1.20.0 version bump, includes - all existing 1.18.4 plugins except for two dropped upstream (gst-plugins-libmms and gst-plugins-ofa) - libnice-0.1.18 version bump required by gst-plugins-webrtc in 1.20.0 - required multilib change for libldac for new plugin gst-plugins-ldac - required multilib change for libopenaptx and libfreeaptx for new plugin gst-plugins-openaptx As discussed, this change adds a LICENSE to each of gstreamer modules which now require explicit opt-in for (A)GPL plugins for (A)GPL plugins we will not perform explicit license acceptance for affected gstreamer plugin, instead we will rely on a user accepting the license of dependency: - gstreamer change added explicit opt-in https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1084 - I looked at affected gstreamer plugins and looks like all are correctly license-compatible according to compatibility matrix https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility - if a user is not willing to accept the license of corresponding (A)GPL dependency, such dependency will not be available and affected gstreamer plugin will not be built - Upstream gstreamer team will look into updating/fixing plugin license display available via gst-inspect-1.0 <plugin name> | grep License as currently it is just "GPL" which is not specific enough (should be GPL-2, GPL-2+, GPL-3 etc.) Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-x265')
-rw-r--r--media-plugins/gst-plugins-x265/Manifest1
-rw-r--r--media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-x265/Manifest b/media-plugins/gst-plugins-x265/Manifest
index 410a851ca65d..0c764d67765f 100644
--- a/media-plugins/gst-plugins-x265/Manifest
+++ b/media-plugins/gst-plugins-x265/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-bad-1.16.3.tar.xz 4900188 BLAKE2B 7d8280a434adb1cb65b065dcdabdb37aad000802c011bb27779c109978d8b75aa4e2fa47043dde95464bb0c34a0d7466dc1f6216f29f0f4911f7a6fe1fb04b25 SHA512 378d8813ba2fd61ea2cab512d5c1fa81e0a4ac4f4ca756547d9b8742e56024c1bc5d6cd332798de66ecfe2b69485c860e181a6c2090398b0e2ad8c4b3fe95d04
DIST gst-plugins-bad-1.18.4.tar.xz 5640292 BLAKE2B 5385abe635a35f61c6780e6cfa1189835877b8c0a12145de6890708a097fc453b1abfb14a3497cae4e6961f71fc2c6e01759fe19386cd30a64c4069704ddf77a SHA512 02123e054419f5ce6ca2ebe0bdf23572269ea4120bf463b4d672efbe5d9e5d417d4d711cc80094be974c4569f754d8b2ad93f59b827e3b018d450582834cb125
+DIST gst-plugins-bad-1.20.0.tar.xz 6203880 BLAKE2B 3c2bcbd5e3af56497415ac9e32b91bf0f9ed0668d6992c8d14b2b56c86be2178ea93409e505d438b56fe87bf75a4c96554fd3cbf9ea5b204b2a520fccb6894fe SHA512 d79fedba96517c25d2ba3925405933671fa05e350b8e133277a7c1d509e08a49ceeb50c016e23e798667fa0b09783105914f06538bdcaae969fdba8ac385a51b
diff --git a/media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.0.ebuild b/media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.0.ebuild
new file mode 100644
index 000000000000..ca3e8f9f303f
--- /dev/null
+++ b/media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-bad"
+
+inherit gstreamer-meson
+
+DESCRIPTION="H.265 encoder plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgpl=enabled
+ )
+
+ gstreamer_multilib_src_configure
+}