summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-09-12 11:14:09 -0400
committerCraig Andrews <candrews@gentoo.org>2019-09-12 11:32:32 -0400
commit887da4092165772b313c27c7f12be9bb5d73c8b2 (patch)
tree12e922ccf204923e12f234502b375bc13c974fd1 /media-plugins/kodi-audiodecoder-sidplay/kodi-audiodecoder-sidplay-1.2.0.ebuild
parentnet-misc/freerdp: fix IUSE sort order (diff)
downloadgentoo-887da4092165772b313c27c7f12be9bb5d73c8b2.tar.gz
gentoo-887da4092165772b313c27c7f12be9bb5d73c8b2.tar.bz2
gentoo-887da4092165772b313c27c7f12be9bb5d73c8b2.zip
media-plugins/kodi-audiodecoder-sidplay: 1.2.0 version bump, EAPI 7, unbundle
Unbundle libsidplay instead dependending on it Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-audiodecoder-sidplay/kodi-audiodecoder-sidplay-1.2.0.ebuild')
-rw-r--r--media-plugins/kodi-audiodecoder-sidplay/kodi-audiodecoder-sidplay-1.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-plugins/kodi-audiodecoder-sidplay/kodi-audiodecoder-sidplay-1.2.0.ebuild b/media-plugins/kodi-audiodecoder-sidplay/kodi-audiodecoder-sidplay-1.2.0.ebuild
new file mode 100644
index 000000000000..e81e5bf4b20e
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-sidplay/kodi-audiodecoder-sidplay-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="SidPlay decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.sidplay"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.sidplay.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.sidplay/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.sidplay-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ media-libs/libsidplay:2"
+
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare(){
+ [ -d depends ] && rm -rf depends || die
+ cmake-utils_src_prepare
+}