summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-01-30 09:59:18 -0500
committerCraig Andrews <candrews@gentoo.org>2020-01-30 10:05:10 -0500
commit81bf5227cba261cc3c6622e2d1f13d8c7f7ab436 (patch)
treecd53f4ecb37e5024510470ee2d709d39ff3fcd0a /media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.60.0.10.ebuild
parentdev-vcs/mercurial: Add upstream (diff)
downloadgentoo-81bf5227cba261cc3c6622e2d1f13d8c7f7ab436.tar.gz
gentoo-81bf5227cba261cc3c6622e2d1f13d8c7f7ab436.tar.bz2
gentoo-81bf5227cba261cc3c6622e2d1f13d8c7f7ab436.zip
media-plugins/kodi-game-libretro-snes9x: 1.60.0.10 version bump
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.60.0.10.ebuild')
-rw-r--r--media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.60.0.10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.60.0.10.ebuild b/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.60.0.10.ebuild
new file mode 100644
index 000000000000..bbf8e92da4aa
--- /dev/null
+++ b/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.60.0.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Snes9x GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.snes9x"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.snes9x.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro.snes9x/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro.snes9x-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ games-emulation/libretro-snes9x
+ "
+RDEPEND="
+ media-plugins/kodi-game-libretro
+ ${DEPEND}
+ "
+src_prepare() {
+ echo 'find_library(SNES9X_LIB NAMES snes9x_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-snes9x.cmake" || die
+ default
+}