summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-28 10:42:14 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-28 10:52:26 -0400
commit91ac4778262f9d07a61b1ed074a673e8c0fcbaf4 (patch)
tree473a0842b3b6a2e412e031c4fcc467376a97b75c /media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.1.ebuild
parentmedia-plugins/kodi-audioencoder-flac: 2.0.3 version bump (diff)
downloadgentoo-91ac4778262f9d07a61b1ed074a673e8c0fcbaf4.tar.gz
gentoo-91ac4778262f9d07a61b1ed074a673e8c0fcbaf4.tar.bz2
gentoo-91ac4778262f9d07a61b1ed074a673e8c0fcbaf4.zip
media-plugins/kodi-game-libretro: 1.1.1 version bump
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.1.ebuild')
-rw-r--r--media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.1.ebuild b/media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.1.ebuild
new file mode 100644
index 000000000000..54e24230f467
--- /dev/null
+++ b/media-plugins/kodi-game-libretro/kodi-game-libretro-1.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/kodi-game/game.libretro"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Leia"
+ SRC_URI="https://github.com/kodi-game/game.libretro/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/game.libretro-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ =dev-libs/libplatform-2*
+ "
+RDEPEND="
+ ${DEPEND}
+ "