summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2023-10-18 10:21:06 +0300
committerSam James <sam@gentoo.org>2023-10-27 04:18:51 +0100
commit8c50d3b35196d6364aa52027fdfaded509f388d5 (patch)
tree7520aca2edacb527183218daa01e63b6da0f3c82 /media-plugins/kodi-inputstream-adaptive
parentsci-astronomy/siril: drop 1.0.6-r2, 1.2.0_rc1-r1 (diff)
downloadgentoo-8c50d3b35196d6364aa52027fdfaded509f388d5.tar.gz
gentoo-8c50d3b35196d6364aa52027fdfaded509f388d5.tar.bz2
gentoo-8c50d3b35196d6364aa52027fdfaded509f388d5.zip
media-plugins/kodi-inputstream-adaptive: fixed build with GCC 13
Closes: https://bugs.gentoo.org/899754 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/33385 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-inputstream-adaptive')
-rw-r--r--media-plugins/kodi-inputstream-adaptive/files/kodi-inputstream-adaptive-19.0.0-gcc-13-fix.patch27
-rw-r--r--media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-19.0.0.ebuild4
2 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-adaptive/files/kodi-inputstream-adaptive-19.0.0-gcc-13-fix.patch b/media-plugins/kodi-inputstream-adaptive/files/kodi-inputstream-adaptive-19.0.0-gcc-13-fix.patch
new file mode 100644
index 000000000000..a9168fe42331
--- /dev/null
+++ b/media-plugins/kodi-inputstream-adaptive/files/kodi-inputstream-adaptive-19.0.0-gcc-13-fix.patch
@@ -0,0 +1,27 @@
+Fix build with GCC 13
+
+Gentoo bug https://bugs.gentoo.org/899754
+
+diff -ur inputstream.adaptive-19.0.0-Matrix/src/helpers.h inputstream.adaptive-19.0.0-Matrix-fixed/src/helpers.h
+--- inputstream.adaptive-19.0.0-Matrix/src/helpers.h 2021-09-14 17:28:17.000000000 +0300
++++ inputstream.adaptive-19.0.0-Matrix-fixed/src/helpers.h 2023-10-18 10:03:57.510248775 +0300
+@@ -19,7 +19,7 @@
+ #pragma once
+
+ #include <string>
+-#include <stdint.h>
++#include <cstdint>
+ #include <vector>
+ #include <map>
+
+diff -ur inputstream.adaptive-19.0.0-Matrix/src/Iaes_decrypter.h inputstream.adaptive-19.0.0-Matrix-fixed/src/Iaes_decrypter.h
+--- inputstream.adaptive-19.0.0-Matrix/src/Iaes_decrypter.h 2021-09-14 17:28:17.000000000 +0300
++++ inputstream.adaptive-19.0.0-Matrix-fixed/src/Iaes_decrypter.h 2023-10-18 10:03:12.136782831 +0300
+@@ -2,6 +2,7 @@
+
+ #include "Ap4Types.h"
+
++#include <cstdint>
+ #include <string>
+
+ class IAESDecrypter
diff --git a/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-19.0.0.ebuild b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-19.0.0.ebuild
index eb913a08d263..03d6ea558f43 100644
--- a/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-19.0.0.ebuild
+++ b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-19.0.0.ebuild
@@ -29,6 +29,10 @@ SLOT="0"
RESTRICT="!test? ( test )"
IUSE="test"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-13-fix.patch # Bug 899754
+)
+
COMMON_DEPEND="
dev-libs/expat
=media-tv/kodi-19*