summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2020-08-03 14:50:19 +0300
committerCraig Andrews <candrews@gentoo.org>2020-08-13 16:50:42 -0400
commit47ec2a3d8046b63f2ebd40f41c3baf0266e25278 (patch)
tree4fe78200d82a17db364787d62c260e32364973ac /media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.9-r1.ebuild
parentmedia-plugins/kodi-inputstream-adaptive: fixed deps, licence; tweaks (diff)
downloadgentoo-47ec2a3d8046b63f2ebd40f41c3baf0266e25278.tar.gz
gentoo-47ec2a3d8046b63f2ebd40f41c3baf0266e25278.tar.bz2
gentoo-47ec2a3d8046b63f2ebd40f41c3baf0266e25278.zip
media-plugins/kodi-inputstream-rtmp: fixed deps, corrected licence pkg-config is required for FindRPMP.cmake rtmpdump should have USE=ssl
Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/16972 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.9-r1.ebuild')
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.9-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.9-r1.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.9-r1.ebuild
new file mode 100644
index 000000000000..420dcee6d343
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-2.0.9-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
+KODI_PLUGIN_NAME="inputstream.rtmp"
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}.git"
+ inherit git-r3
+ DEPEND="~media-tv/kodi-9999"
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}"
+ DEPEND="=media-tv/kodi-18*:="
+ ;;
+esac
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ media-video/rtmpdump[ssl]
+ "
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ if [ -d depends ]; then rm -rf depends || die; fi
+
+ cmake_src_prepare
+}