summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-01-09 15:24:47 -0500
committerDavid Seifert <soap@gentoo.org>2017-01-09 22:25:55 +0200
commit2825b6e93761621c6162913df20b21169df024c8 (patch)
tree9bad032591663c2da65d9c2f00b06ff74e2cc45c /media-plugins/kodi-inputstream-rtmp
parentdev-python/ansicolor: add missing dev-python/setuptools DEPEND (diff)
downloadgentoo-2825b6e93761621c6162913df20b21169df024c8.tar.gz
gentoo-2825b6e93761621c6162913df20b21169df024c8.tar.bz2
gentoo-2825b6e93761621c6162913df20b21169df024c8.zip
media-plugins/kodi-*: add live ebuilds for all add-ons currently available in kodi upstream
Gentoo-bug: 555792 Closes: https://github.com/gentoo/gentoo/pull/3195
Diffstat (limited to 'media-plugins/kodi-inputstream-rtmp')
-rw-r--r--media-plugins/kodi-inputstream-rtmp/Manifest1
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.3.ebuild36
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild36
-rw-r--r--media-plugins/kodi-inputstream-rtmp/metadata.xml16
4 files changed, 89 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/Manifest b/media-plugins/kodi-inputstream-rtmp/Manifest
new file mode 100644
index 000000000000..4b0f88190714
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/Manifest
@@ -0,0 +1 @@
+DIST kodi-inputstream-rtmp-1.0.3.tar.gz 6246 SHA256 d89ebb21256fcac35ddb961d42e2cae7709b15a431e717054a0cab7f9a54b391 SHA512 c11e648f353b8c35e0c2ecd34f5dd8a8805537592886f20a37b6dfdbb2b56bb2c29169ed66086d8c856a14b91a4296277458e32e58e1309defbaf79a3e17015c WHIRLPOOL 0db2af45eed7f81e7e238edbe6b874492d0bc50fc6cd16fa992f7d7ea5a7d2b91b0c9b30eafa5bcded86900f5e7937f5d3a88d00f00336dd29e11e704963c465
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.3.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.3.ebuild
new file mode 100644
index 000000000000..0b2f29c1dfff
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/notspiff/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/notspiff/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/inputstream.rtmp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
new file mode 100644
index 000000000000..0b2f29c1dfff
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/notspiff/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/notspiff/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/inputstream.rtmp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ media-tv/kodi
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-inputstream-rtmp/metadata.xml b/media-plugins/kodi-inputstream-rtmp/metadata.xml
new file mode 100644
index 000000000000..cbc4b114dbc1
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@integralblue.com</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Kodi's RTMP inputstream addon</longdescription>
+ <upstream>
+ <remote-id type="github">notspiff/inputstream.rtmp</remote-id>
+ </upstream>
+</pkgmetadata>