summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-06 10:36:41 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-06 10:58:07 -0500
commitf96d9d6a0bfb17a1f8026b34c42fd296214ebe1d (patch)
tree57a63621fe8d0697905f3e1918de7b1abf6222bd /media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild
parentmedia-plugins/kodi-peripheral-steamcontroller: Fix incorrect HOMEPAGE (diff)
downloadgentoo-f96d9d6a0bfb17a1f8026b34c42fd296214ebe1d.tar.gz
gentoo-f96d9d6a0bfb17a1f8026b34c42fd296214ebe1d.tar.bz2
gentoo-f96d9d6a0bfb17a1f8026b34c42fd296214ebe1d.zip
media-plugins/kodi-pvr-mythtv: 5.8.14 version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild')
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild
new file mode 100644
index 000000000000..05d2594341ea
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="MythTV PVR for Kodi"
+HOMEPAGE="https://github.com/janbar/pvr.mythtv"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/janbar/pvr.mythtv.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ sys-libs/zlib
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ "
+RDEPEND="
+ ${DEPEND}
+ "