summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-28 09:09:16 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-28 09:09:39 -0400
commit9a999ffbbd6b149d47c8e6159cbce6352310d92f (patch)
tree292f094a4c6ad46556667bdf3c5c061e461a1969 /media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-6.4.0.ebuild
parentsci-mathematics/mathematica: Add 12.1.0 for whoever cant get 12.1.1 (diff)
downloadgentoo-9a999ffbbd6b149d47c8e6159cbce6352310d92f.tar.gz
gentoo-9a999ffbbd6b149d47c8e6159cbce6352310d92f.tar.bz2
gentoo-9a999ffbbd6b149d47c8e6159cbce6352310d92f.zip
media-plugins/kodi-pvr-vuplus: 6.4.0 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-6.4.0.ebuild')
-rw-r--r--media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-6.4.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-6.4.0.ebuild b/media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-6.4.0.ebuild
new file mode 100644
index 000000000000..0fb0a0a6a42d
--- /dev/null
+++ b/media-plugins/kodi-pvr-vuplus/kodi-pvr-vuplus-6.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Kodi's VuPlus client addon"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.vuplus"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.vuplus.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.vuplus/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.vuplus-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ dev-libs/tinyxml
+ dev-cpp/nlohmann_json
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
+
+src_prepare() {
+ [ -d depends ] && rm -rf depends || die
+ cmake_src_prepare
+}