summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/libvisual-projectm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/libvisual-projectm')
-rw-r--r--media-plugins/libvisual-projectm/Manifest2
-rw-r--r--media-plugins/libvisual-projectm/files/2.0.1-gcc4.6.patch15
-rw-r--r--media-plugins/libvisual-projectm/libvisual-projectm-2.0.1.ebuild32
-rw-r--r--media-plugins/libvisual-projectm/libvisual-projectm-2.1.0.ebuild31
-rw-r--r--media-plugins/libvisual-projectm/metadata.xml8
5 files changed, 88 insertions, 0 deletions
diff --git a/media-plugins/libvisual-projectm/Manifest b/media-plugins/libvisual-projectm/Manifest
new file mode 100644
index 000000000000..e20d7a0f3347
--- /dev/null
+++ b/media-plugins/libvisual-projectm/Manifest
@@ -0,0 +1,2 @@
+DIST projectM-complete-2.1.0-Source.tar.gz 31130351 SHA256 513204f033006bd3dcdf8aada196d816d6b7187266ddcbb1594d0285cc9406ee SHA512 53f4531208d2594f1c28a7f7842fb5ee3349ca9e48f9f0d999a90b6a62d315c9c0ae9cba1cdfacb8a149eba3e5ddc4517ac406ee2c53718191be8e26ee2cca5f WHIRLPOOL f60ee006dac8465a17e1397a9331bdabd7a3967455f9e16644e1ff5e544ab1662b3aa8a2b428c0258f0b38c91513bfbda3cd29b4419e05e64aa410e61ad03972
+DIST projectM_libvisual-2.0.1-Source.tar.gz 23128 SHA256 8526b8687caebcef5f3374dd61665732f10030e970a7db4804eb65a06da18ea0
diff --git a/media-plugins/libvisual-projectm/files/2.0.1-gcc4.6.patch b/media-plugins/libvisual-projectm/files/2.0.1-gcc4.6.patch
new file mode 100644
index 000000000000..9ae5f609815e
--- /dev/null
+++ b/media-plugins/libvisual-projectm/files/2.0.1-gcc4.6.patch
@@ -0,0 +1,15 @@
+Fix build failure with GCC4.6
+
+http://projectm.svn.sourceforge.net/viewvc/projectm?view=revision&revision=1355
+
+--- trunk/src/projectM-libvisual/actor_projectM.cpp 2009/02/20 19:07:44 1210
++++ trunk/src/projectM-libvisual/actor_projectM.cpp 2011/05/06 12:04:58 1355
+@@ -209,7 +209,7 @@
+ * we aren't with projectm, so just ignore :) */
+ extern "C" VisPalette *lv_projectm_palette (VisPluginData *plugin)
+ {
+- return NULL;
++ return (VisPalette *) NULL;
+ }
+
+ /* This is where the real rendering happens! This function is what we call, many times
diff --git a/media-plugins/libvisual-projectm/libvisual-projectm-2.0.1.ebuild b/media-plugins/libvisual-projectm/libvisual-projectm-2.0.1.ebuild
new file mode 100644
index 000000000000..e885666f3425
--- /dev/null
+++ b/media-plugins/libvisual-projectm/libvisual-projectm-2.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+MY_P=projectM_libvisual-${PV}-Source
+
+DESCRIPTION="A libvisual graphical music visualization plugin similar to milkdrop"
+HOMEPAGE="http://projectm.sourceforge.net"
+SRC_URI="mirror://sourceforge/projectm/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="media-libs/libsdl
+ =media-libs/libvisual-0.4*
+ >=media-libs/libprojectm-2.0.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-gcc4.6.patch"
+)
diff --git a/media-plugins/libvisual-projectm/libvisual-projectm-2.1.0.ebuild b/media-plugins/libvisual-projectm/libvisual-projectm-2.1.0.ebuild
new file mode 100644
index 000000000000..19e20dca2403
--- /dev/null
+++ b/media-plugins/libvisual-projectm/libvisual-projectm-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+MY_P=projectM-complete-${PV}-Source
+
+DESCRIPTION="A libvisual graphical music visualization plugin similar to milkdrop"
+HOMEPAGE="http://projectm.sourceforge.net"
+SRC_URI="mirror://sourceforge/projectm/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="
+ media-libs/libsdl
+ =media-libs/libvisual-0.4*
+ >=media-libs/libprojectm-2.1.0
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}/src/projectM-libvisual/
+
+DOCS="AUTHORS ChangeLog"
diff --git a/media-plugins/libvisual-projectm/metadata.xml b/media-plugins/libvisual-projectm/metadata.xml
new file mode 100644
index 000000000000..2ace5da19108
--- /dev/null
+++ b/media-plugins/libvisual-projectm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">projectm</remote-id>
+ </upstream>
+</pkgmetadata>