summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-06-12 13:34:01 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-06-12 13:43:42 -0500
commit8e14ff1a018a8d131838439a52a4849f675aaa6a (patch)
tree2640a9b9c6f3c9dbba588b943754d891350a45e0 /media-plugins/live
parentmedia-video/mpv: bump libplacebo version for 9999 (diff)
downloadgentoo-8e14ff1a018a8d131838439a52a4849f675aaa6a.tar.gz
gentoo-8e14ff1a018a8d131838439a52a4849f675aaa6a.tar.bz2
gentoo-8e14ff1a018a8d131838439a52a4849f675aaa6a.zip
media-plugins/live: add 2021.05.22
Bug: https://bugs.gentoo.org/732598 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/Manifest1
-rw-r--r--media-plugins/live/live-2021.05.22.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/media-plugins/live/Manifest b/media-plugins/live/Manifest
index fd63e86d4e20..f77ddb4bdae4 100644
--- a/media-plugins/live/Manifest
+++ b/media-plugins/live/Manifest
@@ -1 +1,2 @@
DIST live.2020.05.15.tar.gz 7229400 BLAKE2B 74532c178aa1044750110eb52561b99cd70874574ee84992201a145b18091d4f8475e2a299a83f0fe42c7e64483d46175fb76465a22509db3ba2633aff1327f6 SHA512 d53fb7e8c586f50e561aa361567ccd45babdbbcbe96a06d95e42a04a54b23ac3f474fefcacf94a49b604008623acf06789b92238364713853babbe356eeac4aa
+DIST live.2021.05.22.tar.gz 682749 BLAKE2B 38663f8c5dbd8cccf4e5cfe685b0eb393559195eba852fcdf6c38c7be936948d2727da91e829aedbde08eab6edb6082533d14061edfcf125d82c925bffdb9f90 SHA512 4021cbdaffb48b9b361e931fa71f89db1e116fe8c4e57df78d54493b111a8c6249431cc418a20352a45a75ef240712609eed3aa7468c6049996dd2451ae2941c
diff --git a/media-plugins/live/live-2021.05.22.ebuild b/media-plugins/live/live-2021.05.22.ebuild
new file mode 100644
index 000000000000..8d95043ecf50
--- /dev/null
+++ b/media-plugins/live/live-2021.05.22.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="ssl"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ ssl? (
+ dev-libs/openssl:0=
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( "live-shared/README" )
+
+# Alexis Ballier <aballier@gentoo.org>, Sam James <sam@gentoo.org>
+# Be careful, bump this everytime you bump the package and the ABI has changed.
+# If you don't know, ask someone.
+# You may wish to use a site like https://abi-laboratory.pro/index.php?view=timeline&l=live555
+LIVE_ABI_VERSION=9
+SLOT="0/${LIVE_ABI_VERSION}"
+
+S="${WORKDIR}/live"
+
+src_prepare() {
+ default
+
+ cp "${FILESDIR}/config.gentoo-so-r3" "${S}/config.gentoo-so-r1" || die
+
+ # This is all legacy stuff which needs to be cleaned up
+ case ${CHOST} in
+ *-solaris*)
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live/config.gentoo-so-r1 \
+ || die
+ ;;
+ *-darwin*)
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
+ -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
+ -e '/^LIB_SUFFIX /s/so/dylib/' \
+ live/config.gentoo-so-r1 \
+ || die
+ ;;
+ esac
+}
+
+src_configure() {
+ # This ebuild uses its own build system
+ # We don't want to call ./configure or anything here.
+ # The only thing we can do is honour the user's SSL preference.
+ if use ssl ; then
+ sed -i 's/-DNO_OPENSSL=1//' "${S}/config.gentoo-so-r1" || die
+ fi
+
+ # Bug 718912
+ tc-export CC CXX
+
+ # And defer to the scripts that upstream provide.
+ ./genMakefiles gentoo-so-r1 || die
+}
+
+src_compile() {
+ export suffix="${LIVE_ABI_VERSION}.so"
+ local link_opts="$(usex ssl "$($(tc-getPKG_CONFIG) --libs libssl libcrypto)" '') -L. ${LDFLAGS}"
+ local lib_suffix="${suffix#.}"
+
+ einfo "Beginning shared library build"
+ emake LINK_OPTS="${link_opts}" LIB_SUFFIX="${lib_suffix}"
+
+ for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
+ cd "${S}/${i}" || die
+ ln -s "lib${i}.${suffix}" "lib${i}.so" || die
+ done
+
+ einfo "Beginning programs build"
+ for i in proxyServer mediaServer ; do
+ cd "${S}/${i}" || die
+ emake LINK_OPTS="${link_opts}"
+ done
+}
+
+src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock ; do
+ dolib.so "${S}/${library}/lib${library}.${suffix}"
+ dosym "lib${library}.${suffix}" "/usr/$(get_libdir)/lib${library}.so"
+
+ insinto /usr/include/"${library}"
+ doins "${S}/${library}"/include/*h
+ done
+
+ dobin "${S}"/mediaServer/live555MediaServer
+ dobin "${S}"/proxyServer/live555ProxyServer
+}