summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-14 18:51:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-14 18:51:20 +0200
commitb453edd714e673cb33b48edba5a7d9a1a1f29c19 (patch)
treeb2f41401123ab8ff5cf2877cfe18ee34eb5948f0 /media-plugins/live
parentmedia-video/mkvtoolnix: bump to 9.4.2 (diff)
downloadgentoo-b453edd714e673cb33b48edba5a7d9a1a1f29c19.tar.gz
gentoo-b453edd714e673cb33b48edba5a7d9a1a1f29c19.tar.bz2
gentoo-b453edd714e673cb33b48edba5a7d9a1a1f29c19.zip
media-plugins/live: bump to 2016.09.12
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/Manifest1
-rw-r--r--media-plugins/live/live-2016.09.12.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/media-plugins/live/Manifest b/media-plugins/live/Manifest
index bbf082689f08..51e3e599a9b6 100644
--- a/media-plugins/live/Manifest
+++ b/media-plugins/live/Manifest
@@ -4,3 +4,4 @@ DIST live.2016.06.26.tar.gz 619580 SHA256 363680367708e5a6f5e7b79b09623f7b4f1917
DIST live.2016.07.19.tar.gz 619591 SHA256 a86abfb8d0bdb04e2d0e1ae07de4eb03b8f4da899c1c28946f1fc6ace9624065 SHA512 b3209042dc53a5e4abd43bbd58f0f4599e694dd6ece92289dfa914dc5b35ecf6aa202f79e0eeaff45088007be2aa4df7b0cfc1c979e8a9caacc16952e41a27ce WHIRLPOOL ee741793663e88bf99e31672b398a808b747eee20d4a3d5b3eb8be6e36ccbf6fec93dceee5ac89e6cd0225ee360333b5a29e71edd865c8870570a09991ab9f79
DIST live.2016.08.27.tar.gz 619652 SHA256 2fd0bcb4b4f0dc15991550b0080eebc4cf586d8f1678c116f8e7a5ec1edbc034 SHA512 e1a43ebada300bd7ef6a3e29a073a9b87d27d5b1076516c21c5f76db57c6088f8477110316c234201c97214f7a78d27cda3b963db1d7d15e46ec189c918a4a85 WHIRLPOOL dbf30a36a2016c913a6a81555c1d485a5247f1499f24eea681fadfa7bea640d9cee2b962f2c23f2ac0c5f3f12b39ca904547089b8ceb6e127a3efc7c31ccbb40
DIST live.2016.09.05.tar.gz 619725 SHA256 afd7bd5fd928737b4ae73bb2557cd6e84aa1eb1c9c9e7d6e9b103954ee2a8cee SHA512 0098d26195879c6a9915aef99e41049bdc2244d04209477b2943aa031c6e1b64775d27a3bd1d089e6b6d420d51cc076caeeda20b16f14b6e72b730499d38cec9 WHIRLPOOL 8952e8fe418f6efe3732ddd3e9a2df67b5fe580b9d163726d0517b30acead2ab19526b02def6fa55a288c66659229cc7173aabc2301eaff67e6e2bfc083f8bd7
+DIST live.2016.09.12.tar.gz 619910 SHA256 09a046d0bf952291d4d70c26de4741ac11f049ee737592e6a251073cb3ecf9e0 SHA512 d45e5a47676e14df17676f25f1ffbd37f43f5f34e5553723e429b28d56a127065620427c1e007cec9a0ef214c6167b039dca89d9c06c291caab36a7e0ba10978 WHIRLPOOL 0114694ce7c2009c69e25dad89084f4619fcd6ed536d0018588b2098e9c80ae1e342c035f2999e01fc2a183e40ce12b1ea22b9f2fc7cbdda8b436479b106db00
diff --git a/media-plugins/live/live-2016.09.12.ebuild b/media-plugins/live/live-2016.09.12.ebuild
new file mode 100644
index 000000000000..f8ef23f1e3be
--- /dev/null
+++ b/media-plugins/live/live-2016.09.12.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz
+ mirror://gentoo/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples static-libs"
+DOCS=( "live-shared/README" )
+
+# Alexis Ballier <aballier@gentoo.org>
+# Be careful, bump this everytime you bump the package and the ABI has changed.
+# If you don't know, ask someone.
+LIVE_ABI_VERSION=7
+SLOT="0/${LIVE_ABI_VERSION}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${S}"
+ mv "${WORKDIR}/live" "${S}/" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-recursive2.patch"
+
+ if use static-libs ; then
+ cp -pPR live live-shared
+ mv live live-static
+ else
+ mv live live-shared
+ fi
+
+ use static-libs && cp "${FILESDIR}/config.gentoo" live-static
+ cp "${FILESDIR}/config.gentoo-so-r1" live-shared
+
+ case ${CHOST} in
+ *-solaris*)
+ use static-libs && { sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live-static/config.gentoo \
+ || die ; }
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live-shared/config.gentoo-so-r1 \
+ || die
+ ;;
+ *-darwin*)
+ use static-libs && { sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
+ live-static/config.gentoo \
+ || die static ; }
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
+ -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
+ -e '/^LIB_SUFFIX /s/so/dylib/' \
+ live-shared/config.gentoo-so-r1 \
+ || die shared
+ ;;
+ esac
+ multilib_copy_sources
+}
+
+src_configure() { :; }
+
+multilib_src_compile() {
+ tc-export CC CXX LD
+
+ if use static-libs ; then
+ cd "${BUILD_DIR}/live-static"
+
+ einfo "Beginning static library build"
+ ./genMakefiles gentoo
+ emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
+ fi
+
+ cd "${BUILD_DIR}/live-shared"
+ einfo "Beginning shared library build"
+ ./genMakefiles gentoo-so-r1
+ local suffix=$(get_libname ${LIVE_ABI_VERSION})
+ emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
+
+ for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
+ pushd "${BUILD_DIR}/live-shared/${i}" > /dev/null
+ ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
+ popd > /dev/null
+ done
+
+ if multilib_is_native_abi; then
+ einfo "Beginning programs build"
+ for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
+ cd "${BUILD_DIR}/live-shared/${i}"
+ emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
+ done
+ fi
+}
+
+multilib_src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
+ use static-libs && dolib.a live-static/${library}/lib${library}.a
+ dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
+ dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
+
+ insinto /usr/include/${library}
+ doins live-shared/${library}/include/*h
+ done
+
+ if multilib_is_native_abi; then
+ # Should we really install these?
+ use examples && find live-shared/testProgs -type f -perm 755 -print0 | \
+ xargs -0 dobin
+
+ dobin live-shared/mediaServer/live555MediaServer
+ dobin live-shared/proxyServer/live555ProxyServer
+ fi
+}