summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon van der Veldt <simon.vanderveldt@gmail.com>2017-03-15 22:41:11 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-16 10:10:00 +0100
commit7528e271c4644aa794116f4255077fa7ad8d6983 (patch)
treef0fc7a93d148aa6c57091e6565f4b01b12c8cc45 /media-plugins/swh-lv2/swh-lv2-1.0.16.ebuild
parentnet-dns/libidn2: arm ppc ppc64 stable (bug 612376). (diff)
downloadgentoo-7528e271c4644aa794116f4255077fa7ad8d6983.tar.gz
gentoo-7528e271c4644aa794116f4255077fa7ad8d6983.tar.bz2
gentoo-7528e271c4644aa794116f4255077fa7ad8d6983.zip
media-plugins/swh-lv2: Version bump to 1.0.16
https://bugs.gentoo.org/show_bug.cgi?id=600854
Diffstat (limited to 'media-plugins/swh-lv2/swh-lv2-1.0.16.ebuild')
-rw-r--r--media-plugins/swh-lv2/swh-lv2-1.0.16.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-plugins/swh-lv2/swh-lv2-1.0.16.ebuild b/media-plugins/swh-lv2/swh-lv2-1.0.16.ebuild
new file mode 100644
index 000000000000..64a3d4b8981d
--- /dev/null
+++ b/media-plugins/swh-lv2/swh-lv2-1.0.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Large collection of LV2 audio plugins/effects"
+HOMEPAGE="http://plugin.org.uk/"
+SRC_URI="https://github.com/swh/lv2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lv2-${PV}"
+
+src_prepare() {
+ sed -e 's:-O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops::g' \
+ -i Makefile || die
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system || die
+ dodoc README
+}