summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-epgsearch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-epgsearch')
-rw-r--r--media-plugins/vdr-epgsearch/Manifest2
-rw-r--r--media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.25.diff32
-rw-r--r--media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff120
-rw-r--r--media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-2.1.2.diff15
-rw-r--r--media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.1_beta5_makefile.diff25
-rw-r--r--media-plugins/vdr-epgsearch/metadata.xml18
-rw-r--r--media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild113
-rw-r--r--media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.1_p20141227.ebuild100
8 files changed, 425 insertions, 0 deletions
diff --git a/media-plugins/vdr-epgsearch/Manifest b/media-plugins/vdr-epgsearch/Manifest
new file mode 100644
index 000000000000..8633b0996573
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/Manifest
@@ -0,0 +1,2 @@
+DIST vdr-epgsearch-1.0.0.tgz 667633 SHA256 989c3ce611ad2b591783dcd7e52a4b462b3352a7657c478e7a3b3c38164b4a12 SHA512 3105dc847a75ad54ca854418a83db847942ba1d85f1c65a94b88310dfcdd5d614b89f0f27fd3ffc8e8c5db6c1c1e0f36e8e7a33cc71299922287f2d19dd385af WHIRLPOOL a661d76f05739d8f411ff8c1dace9b1c059e33d04a87698578a9cecf31bdf4ebc6d41bf9fce21338bafd001f0d1d386a19b08d7a1188081d33ff6f7b9a45a979
+DIST vdr-epgsearch-1.0.1_p20141227.tar.gz 472802 SHA256 f53fd19aab6acca45f345b889eea592affcb18fe6c9e48294fda182c80a53b5f SHA512 952d58f6f03d2804f97be14779faf37c3788b42d78a6460102e2f1c74f6a58d7d68639e7e95e40f27417ce3658c0d5bf856399b6e8e8c214ea143d2865507562 WHIRLPOOL 27d905c7d4430040848c844975000d21fb64d789e230f6f8c57599278f4440b4a3435abe4260d1bc2be3f5fcec70ad9ea9baf734a43a2bd52c7fb69cae44fb98
diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.25.diff b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.25.diff
new file mode 100644
index 000000000000..3a8babbc16fb
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.25.diff
@@ -0,0 +1,32 @@
+--- epgsearch/conflictcheck.h.bak 2012-03-03 15:33:15.000000000 +0100
++++ epgsearch/conflictcheck.h 2012-03-03 15:35:43.000000000 +0100
+@@ -169,12 +169,12 @@
+ result = true;
+ #ifdef DO_REC_AND_PLAY_ON_PRIMARY_DEVICE
+ else
+- result = Priority >= Setup.PrimaryLimit;
++ result = Priority >= 0;
+ #endif
+ #endif
+ }
+ else
+- result = !IsPrimaryDevice() || Priority >= Setup.PrimaryLimit;
++ result = !IsPrimaryDevice() || Priority >= 0;
+ }
+ else
+ needsDetachReceivers = true;
+@@ -259,12 +259,12 @@
+ result = true;
+ #ifdef DO_REC_AND_PLAY_ON_PRIMARY_DEVICE
+ else
+- result = Priority >= Setup.PrimaryLimit;
++ result = Priority >= 0;
+ #endif
+ #endif
+ }
+ else
+- result = !IsPrimaryDevice() || Priority >= Setup.PrimaryLimit;
++ result = !IsPrimaryDevice() || Priority >= 0;
+ }
+ else
+ needsDetachReceivers = true;
diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff
new file mode 100644
index 000000000000..aa51685cb282
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-1.7.33.diff
@@ -0,0 +1,120 @@
+diff -Naur epgsearch-1.0.0.orig/epgsearchsvdrp.c epgsearch-1.0.0/epgsearchsvdrp.c
+--- epgsearch-1.0.0.orig/epgsearchsvdrp.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/epgsearchsvdrp.c 2012-12-15 11:44:38.000000000 +0100
+@@ -564,7 +564,7 @@
+ strftime(bufStart, sizeof(bufStart), "%H%M", localtime_r(&start, &tm_r));
+ strftime(bufEnd, sizeof(bufEnd), "%H%M", localtime_r(&stop, &tm_r));
+
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool hasTimer = false;
+ if (Timers.GetMatch(pEvent, &timerMatch))
+ hasTimer = (timerMatch == tmFull);
+diff -Naur epgsearch-1.0.0.orig/mail.c epgsearch-1.0.0/mail.c
+--- epgsearch-1.0.0.orig/mail.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/mail.c 2012-12-15 11:45:02.000000000 +0100
+@@ -49,7 +49,7 @@
+ const cEvent* pEvent = GetEvent();
+ if (!pEvent) return "";
+
+- int TimerMatch = tmNone;
++ eTimerMatch TimerMatch = tmNone;
+ cTimer* pTimer = Timers.GetMatch(pEvent, &TimerMatch);
+ if (!pTimer) return "";
+
+diff -Naur epgsearch-1.0.0.orig/menu_commands.c epgsearch-1.0.0/menu_commands.c
+--- epgsearch-1.0.0.orig/menu_commands.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_commands.c 2012-12-15 11:45:40.000000000 +0100
+@@ -121,7 +121,7 @@
+ {
+ if (!event) return osContinue;
+
+- int timerMatch = tmNone;
++ eTimerMatch timerMatch = tmNone;
+ cTimer* timer = Timers.GetMatch(event, &timerMatch);
+ if (timerMatch == tmFull)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_event.c epgsearch-1.0.0/menu_event.c
+--- epgsearch-1.0.0.orig/menu_event.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_event.c 2012-12-15 11:46:17.000000000 +0100
+@@ -92,7 +92,7 @@
+ cEventObj* eventObjPrev = GetPrev(event);
+ cEventObj* eventObjNext = GetNext(event);
+
+- int timerMatch = tmNone;
++ eTimerMatch timerMatch = tmNone;
+ Timers.GetMatch(event, &timerMatch);
+ const char* szRed = trVDR("Button$Record");
+ if (timerMatch == tmFull)
+diff -Naur epgsearch-1.0.0.orig/menu_main.c epgsearch-1.0.0/menu_main.c
+--- epgsearch-1.0.0.orig/menu_main.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_main.c 2012-12-15 11:47:08.000000000 +0100
+@@ -181,7 +181,7 @@
+ if (item) {
+ if (item->timerMatch == tmFull)
+ {
+- int tm = tmNone;
++ eTimerMatch tm = tmNone;
+ cTimer *timer = Timers.GetMatch(item->event, &tm);
+ if (timer)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_searchresults.c epgsearch-1.0.0/menu_searchresults.c
+--- epgsearch-1.0.0.orig/menu_searchresults.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_searchresults.c 2012-12-15 11:51:12.000000000 +0100
+@@ -217,7 +217,7 @@
+ if (item) {
+ if (item->timerMatch == tmFull)
+ {
+- int tm = tmNone;
++ eTimerMatch tm = tmNone;
+ cTimer *timer = Timers.GetMatch(item->event, &tm);
+ if (timer)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_searchresults.h epgsearch-1.0.0/menu_searchresults.h
+--- epgsearch-1.0.0.orig/menu_searchresults.h 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_searchresults.h 2012-12-15 11:51:57.000000000 +0100
+@@ -50,7 +50,7 @@
+ bool episodeOnly;
+ cMenuTemplate* menuTemplate;
+ public:
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool inSwitchList;
+ const cEvent *event;
+ const cSearchExt* search;
+diff -Naur epgsearch-1.0.0.orig/menu_whatson.c epgsearch-1.0.0/menu_whatson.c
+--- epgsearch-1.0.0.orig/menu_whatson.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_whatson.c 2012-12-15 11:52:37.000000000 +0100
+@@ -527,7 +527,7 @@
+ {
+ if (item->timerMatch == tmFull)
+ {
+- int tm = tmNone;
++ eTimerMatch tm = tmNone;
+ cTimer *timer = Timers.GetMatch(item->event, &tm);
+ if (timer)
+ {
+diff -Naur epgsearch-1.0.0.orig/menu_whatson.h epgsearch-1.0.0/menu_whatson.h
+--- epgsearch-1.0.0.orig/menu_whatson.h 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/menu_whatson.h 2012-12-15 11:53:09.000000000 +0100
+@@ -35,7 +35,7 @@
+ const cEvent *event;
+ cChannel *channel;
+ showMode mode;
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool inSwitchList;
+ cMenuTemplate* menuTemplate;
+
+diff -Naur epgsearch-1.0.0.orig/services.c epgsearch-1.0.0/services.c
+--- epgsearch-1.0.0.orig/services.c 2012-12-15 11:42:41.000000000 +0100
++++ epgsearch-1.0.0/services.c 2012-12-15 11:53:34.000000000 +0100
+@@ -143,7 +143,7 @@
+ strftime(bufStart, sizeof(bufStart), "%H%M", localtime_r(&start, &tm_r));
+ strftime(bufEnd, sizeof(bufEnd), "%H%M", localtime_r(&stop, &tm_r));
+
+- int timerMatch;
++ eTimerMatch timerMatch;
+ bool hasTimer = false;
+ if (Timers.GetMatch(pEvent, &timerMatch))
+ hasTimer = (timerMatch == tmFull);
diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-2.1.2.diff b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-2.1.2.diff
new file mode 100644
index 000000000000..5b9d657e95ec
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.0_vdr-2.1.2.diff
@@ -0,0 +1,15 @@
+diff -Naur epgsearch-1.0.0.orig/uservars.h epgsearch-1.0.0/uservars.h
+--- epgsearch-1.0.0.orig/uservars.h 2013-10-23 00:54:29.000000000 +0200
++++ epgsearch-1.0.0/uservars.h 2013-10-23 00:56:21.000000000 +0200
+@@ -537,7 +537,11 @@
+ cVideodirVar() : cInternalVar("%videodir%") {}
+ string Evaluate(const cEvent*, bool escapeStrings = false)
+ {
++#if APIVERSNUM > 20101
++ return cVideoDirectory::Name();
++#else
+ return VideoDirectory;
++#endif
+ }
+ };
+
diff --git a/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.1_beta5_makefile.diff b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.1_beta5_makefile.diff
new file mode 100644
index 000000000000..25e27e958a4a
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/files/vdr-epgsearch-1.0.1_beta5_makefile.diff
@@ -0,0 +1,25 @@
+diff -Naur vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile
+--- vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42.orig/Makefile 2015-02-21 21:01:08.926052710 +0100
++++ vdr-plugin-epgsearch-a908daa4c5c6edd6c560ed96939358b4352e9b42/Makefile 2015-02-21 21:03:42.768052710 +0100
+@@ -255,9 +255,9 @@
+ docs:
+ ./docsrc2man.sh
+ ./docsrc2html.sh
+- ln -sf ./doc/en/epgsearch.4.txt MANUAL
+- ln -sf ./doc/en/epgsearch.1.txt README
+- ln -sf ./doc/de/epgsearch.1.txt README.DE
++# ln -sf ./doc/en/epgsearch.4.txt MANUAL
++# ln -sf ./doc/en/epgsearch.1.txt README
++# ln -sf ./doc/de/epgsearch.1.txt README.DE
+
+ install-$(PLUGIN): libvdr-$(PLUGIN).so
+ install -D libvdr-$(PLUGIN).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
+@@ -272,7 +272,7 @@
+ install -D libvdr-$(PLUGIN4).so $(DESTDIR)$(LIBDIR)/libvdr-$(PLUGIN4).so.$(APIVERSION)
+
+ install-conf:
+- mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)/conf.d
++ mkdir -p $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)
+ cp -n conf/* $(DESTDIR)$(CONFDIR)/plugins/$(PLUGIN)
+
+ install-doc:
diff --git a/media-plugins/vdr-epgsearch/metadata.xml b/media-plugins/vdr-epgsearch/metadata.xml
new file mode 100644
index 000000000000..256c7092e6cf
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+<use>
+ <flag name="conflictcheckonly">ToDo</flag>
+ <flag name="epgsearchonly">ToDo</flag>
+ <flag name="quicksearch">ToDo</flag>
+ <flag name="tre">Add support for unlimited fuzzy searching with help of <pkg>dev-libs/tre</pkg> library</flag>
+</use>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..dedffa212dbc
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.0-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Searchtimer and replacement of the VDR program menu"
+HOMEPAGE="http://winni.vdr-developer.org/epgsearch"
+
+case ${P#*_} in
+ rc*|beta*)
+ MY_P="${P/_/.}"
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/beta/${MY_P}.tgz"
+ S="${WORKDIR}/${MY_P#vdr-}"
+ ;;
+ *)
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/${P}.tgz"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="pcre tre linguas_de"
+
+DEPEND=">=media-video/vdr-1.3.45
+ pcre? ( dev-libs/libpcre )
+ tre? ( dev-libs/tre )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="pcre? ( !tre )
+ tre? ( !pcre )"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include conflictcheck.c
+
+ if has_version ">=media-video/vdr-1.7.25"; then
+ epatch "${FILESDIR}/${P}_vdr-1.7.25.diff"
+ fi
+
+ if has_version ">=media-video/vdr-1.7.28"; then
+ sed -i "s:SetRecording(recording->FileName(), recording->Title:SetRecording(recording->FileName:" menu_searchresults.c
+ fi
+
+ if has_version ">=media-video/vdr-1.7.33"; then
+ epatch "${FILESDIR}/${P}_vdr-1.7.33.diff"
+ fi
+
+ epatch "${FILESDIR}/${P}_vdr-2.1.2.diff"
+
+ # disable automagic deps
+ sed -i Makefile -e '/^AUTOCONFIG=/s/^/#/'
+
+ if use pcre; then
+ einfo "Using pcre for regexp searches"
+ sed -i Makefile -e 's:^#REGEXLIB = pcre:REGEXLIB = pcre:'
+ fi
+
+ if use tre; then
+ einfo "Using tre for unlimited fuzzy searches"
+ sed -i Makefile -e 's:^#REGEXLIB = pcre:REGEXLIB = tre:'
+ fi
+
+ # install conf-file disabled
+ sed -e '/^Menu/s:^:#:' -i conf/epgsearchmenu.conf
+
+ # Get a rid of the broken symlinks
+ rm -f README{,.DE} MANUAL
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ diropts "-m755 -o vdr -g vdr"
+ keepdir /etc/vdr/plugins/epgsearch
+ insinto /etc/vdr/plugins/epgsearch
+
+ doins conf/epgsearchmenu.conf
+ doins conf/epgsearchconflmail.templ conf/epgsearchupdmail.templ
+
+ dodoc conf/*.templ
+
+ doman man/en/*.gz
+
+ if use linguas_de; then
+ doman -i18n=de man/de/*.gz
+ fi
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.9.18"
+ previous_less_than_0_9_18=$?
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+ if [[ $previous_less_than_0_9_18 = 0 ]] ; then
+ elog "Moving config-files to new location /etc/vdr/plugins/epgsearch"
+ cd "${ROOT}"/etc/vdr/plugins
+ local f
+ local moved=""
+ for f in epgsearch*.* .epgsearch*; do
+ [[ -e ${f} ]] || continue
+ mv "${f}" "${ROOT}/etc/vdr/plugins/epgsearch"
+ moved="${moved} ${f}"
+ done
+ elog "These files were moved:${moved}"
+ fi
+}
diff --git a/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.1_p20141227.ebuild b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.1_p20141227.ebuild
new file mode 100644
index 000000000000..d45cd4b4afa8
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/vdr-epgsearch-1.0.1_p20141227.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: create timers from epg content based on saved search expressions"
+HOMEPAGE="http://winni.vdr-developer.org/epgsearch"
+
+case ${P#*_} in
+ rc*|beta*)
+ MY_P="${P/_/.}"
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/beta/${MY_P}.tgz"
+ S="${WORKDIR}/${MY_P#vdr-}"
+ ;;
+ p*)
+ GIT_COMMIT_ID="a908daa4c5c6edd6c560ed96939358b4352e9b42"
+ GIT_COMMIT_DATE="20141227"
+ SRC_URI="http://projects.vdr-developer.org/git/vdr-plugin-epgsearch.git/snapshot/vdr-plugin-epgsearch-${GIT_COMMIT_ID}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/vdr-plugin-epgsearch-${GIT_COMMIT_ID}"
+ ;;
+ *)
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/${P}.tgz"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+conflictcheckonly +epgsearchonly linguas_de pcre +quicksearch tre"
+
+DEPEND="media-video/vdr
+ pcre? ( dev-libs/libpcre )
+ tre? ( dev-libs/tre )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="pcre? ( !tre )
+ tre? ( !pcre )"
+
+src_prepare() {
+ # make detection in vdr-plugin-2.eclass for new Makefile handling happy
+ echo "# SOFILE" >> Makefile
+
+ # remove untranslated .po files
+ rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ epatch "${FILESDIR}/vdr-epgsearch-1.0.1_beta5_makefile.diff"
+
+ use conflictcheckonly || sed -e "s:install-\$(PLUGIN3)::" -i Makefile
+ use epgsearchonly || sed -e "s:install-\$(PLUGIN2)::" -i Makefile
+ use quicksearch || sed -e "s:install-\$(PLUGIN4)::" -i Makefile
+
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include conflictcheck.c
+
+ # install conf-file disabled
+ sed -e '/^Menu/s:^:#:' -i conf/epgsearchmenu.conf
+
+ # Get rid of the broken symlinks
+ rm -f README{,.DE} MANUAL
+}
+
+src_compile() {
+ BUILD_PARAMS="SENDMAIL=/usr/bin/sendmail AUTOCONFIG=0"
+
+ if use pcre; then
+ BUILD_PARAMS+=" REGEXLIB=pcre"
+ einfo "Using pcre for regexp searches"
+ fi
+
+ if use tre; then
+ BUILD_PARAMS+=" REGEXLIB=tre"
+ einfo "Using tre for unlimited fuzzy searches"
+ fi
+
+ vdr-plugin-2_src_compile
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ diropts "-m755 -o vdr -g vdr"
+ keepdir /etc/vdr/plugins/epgsearch
+ insinto /etc/vdr/plugins/epgsearch
+
+ doins conf/epgsearchmenu.conf
+ doins conf/epgsearchconflmail.templ conf/epgsearchupdmail.templ
+
+ nonfatal dodoc conf/*.templ HISTORY*
+
+ doman man/en/*.gz
+
+ if use linguas_de; then
+ doman -i18n=de man/de/*.gz
+ fi
+}