summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-ffnetdev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-ffnetdev')
-rw-r--r--media-plugins/vdr-ffnetdev/Manifest1
-rw-r--r--media-plugins/vdr-ffnetdev/files/confd38
-rw-r--r--media-plugins/vdr-ffnetdev/files/rc-addon.sh19
-rw-r--r--media-plugins/vdr-ffnetdev/files/vdr-ffnetdev-0.1.2_gettext.diff126
-rw-r--r--media-plugins/vdr-ffnetdev/metadata.xml10
-rw-r--r--media-plugins/vdr-ffnetdev/vdr-ffnetdev-0.1.2.ebuild29
6 files changed, 223 insertions, 0 deletions
diff --git a/media-plugins/vdr-ffnetdev/Manifest b/media-plugins/vdr-ffnetdev/Manifest
new file mode 100644
index 000000000000..22ecf4ebc18f
--- /dev/null
+++ b/media-plugins/vdr-ffnetdev/Manifest
@@ -0,0 +1 @@
+DIST vdr-ffnetdev-0.1.2.tar.bz2 56059 SHA256 cf9bd65d3f475963ddd78133d8fbc3678383fef99259b975b6a073debce1bc8a SHA512 5583a0c1ea7a421a745704a4440f25c9b35ed72686baeacaa67324e0c1a51f7a4a2d0ff4840ffb0b7086b4d310f48141cd001889692a1c1987a246d999c9afd6 WHIRLPOOL f77b7a0f2f5eb56a1e2e0ff6dd31c3b8c953fcec82f3eb0b9ac7cc1a0b2bb9385046220e2125a8694e442dd7da0461548d6bb848edd07ab6a269c803bded1862
diff --git a/media-plugins/vdr-ffnetdev/files/confd b/media-plugins/vdr-ffnetdev/files/confd
new file mode 100644
index 000000000000..8533dd415d4f
--- /dev/null
+++ b/media-plugins/vdr-ffnetdev/files/confd
@@ -0,0 +1,38 @@
+# /etc/conf.d/vdr.ffnetdev
+# $Id$
+
+## listen on this port for OSD connect
+# available Parameter are portnumber
+# default port 20001
+#
+#VNC_PORT="20001"
+#
+## enable VNC
+# available Parameter yes | no
+#
+USE_VNC="no"
+
+
+## port number for sending TS
+# available Parameter ar portnumber
+# default port 20002
+#
+#TS_PORT="20002"
+#
+## anable TS
+# availabel Parameter yes | no
+#
+USE_TS="no"
+
+## enable remote control over OSD connection
+# available parameter yes | no
+# default no
+#
+REMOTE="no"
+
+## Detail from README
+#
+# Option registers a new remote control object causing VDR to start the
+# learning procedure for this new remote control if you start
+# VDR and the ffnetdev plugin for the first time.
+# If you want to control VDR over SVDRP you can simply leave it. \ No newline at end of file
diff --git a/media-plugins/vdr-ffnetdev/files/rc-addon.sh b/media-plugins/vdr-ffnetdev/files/rc-addon.sh
new file mode 100644
index 000000000000..e6222962992c
--- /dev/null
+++ b/media-plugins/vdr-ffnetdev/files/rc-addon.sh
@@ -0,0 +1,19 @@
+# $Id$
+#
+# rc-addon-script for plugin ffnetdev
+#
+# Joerg Bornkessel <hd_brummy@gentoo.org>
+
+: ${VNC_PORT:=20001}
+: ${TS_PORT:=20002}
+
+plugin_pre_vdr_start() {
+
+ [ "${USE_VNC}" = "yes" ] && add_plugin_param "-o ${VNC_PORT}"
+
+ [ "${USE_TS}" = "yes" ] && add_plugin_param "-t ${TS_PORT}"
+
+ [ "${REMOTE}" = "yes" ] && add_plugin_param "-e"
+
+ return 0
+}
diff --git a/media-plugins/vdr-ffnetdev/files/vdr-ffnetdev-0.1.2_gettext.diff b/media-plugins/vdr-ffnetdev/files/vdr-ffnetdev-0.1.2_gettext.diff
new file mode 100644
index 000000000000..061ac40bcede
--- /dev/null
+++ b/media-plugins/vdr-ffnetdev/files/vdr-ffnetdev-0.1.2_gettext.diff
@@ -0,0 +1,126 @@
+converting to gettext
+https://bugs.gentoo.org/show_bug.cgi?id=439970
+Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org>
+diff -Naur vdr-ffnetdev-0.1.2.orig/ffnetdev.c vdr-ffnetdev-0.1.2/ffnetdev.c
+--- vdr-ffnetdev-0.1.2.orig/ffnetdev.c 2012-10-31 18:32:09.000000000 +0100
++++ vdr-ffnetdev-0.1.2/ffnetdev.c 2012-10-31 18:34:05.000000000 +0100
+@@ -10,7 +10,7 @@
+
+ #include <vdr/tools.h>
+
+-#include "i18n.h"
++#include <vdr/i18n.h>
+ #include "tsworker.h"
+ #include "netosd.h"
+ #include "ffnetdev.h"
+@@ -22,7 +22,7 @@
+
+
+ const char *cPluginFFNetDev::VERSION = "0.1.2";
+-const char *cPluginFFNetDev::DESCRIPTION = "Full Featured Network Device for Streaming";
++const char *cPluginFFNetDev::DESCRIPTION = trNOOP("Full Featured Network Device for Streaming");
+ //const char *cOSDWorker::MAINMENUENTRY = "FFNetDev";
+
+ // --- cNetOSDProvider -----------------------------------------------
+@@ -163,9 +163,6 @@
+ bool cPluginFFNetDev::Start(void)
+ {
+ // Start any background activities the plugin shall perform.
+- RegisterI18n(Phrases);
+-
+-
+ cOSDWorker::Init(OSDPort, this);
+ cTSWorker::Init(m_StreamDevice, TSPort, this);
+ cClientControl::Init(ControlPort, this);
+diff -Naur vdr-ffnetdev-0.1.2.orig/Makefile vdr-ffnetdev-0.1.2/Makefile
+--- vdr-ffnetdev-0.1.2.orig/Makefile 2012-10-31 18:32:09.000000000 +0100
++++ vdr-ffnetdev-0.1.2/Makefile 2012-10-31 18:37:10.000000000 +0100
+@@ -50,9 +50,7 @@
+
+ ### The object files (add further files here):
+
+-COMMONOBJS = i18n.o \
+- \
+- tools/source.o tools/select.o tools/socket.o tools/tools.o
++COMMONOBJS = tools/source.o tools/select.o tools/socket.o tools/tools.o
+
+
+ SERVEROBJS = $(PLUGIN).o \
+@@ -95,9 +93,34 @@
+
+ -include $(DEPFILE)
+
++### Internationalization (I18N):
++
++PODIR = po
++LOCALEDIR = $(VDRDIR)/locale
++I18Npo = $(wildcard $(PODIR)/*.po)
++I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
++I18Ndirs = $(notdir $(foreach file, $(I18Npo), $(basename $(file))))
++I18Npot = $(PODIR)/$(PLUGIN).pot
++
++%.mo: %.po
++ msgfmt -c -o $@ $<
++
++$(I18Npot): $(wildcard *.c)
++ xgettext -C -cTRANSLATORS --no-wrap -F -k -ktr -ktrNOOP --msgid-bugs-address='<dev@erichseifert.de>' -o $@ $(wildcard *.c)
++
++$(I18Npo): $(I18Npot)
++ msgmerge -U --no-wrap -F --backup=none -q $@ $<
++
++i18n: $(I18Nmo)
++ @mkdir -p $(LOCALEDIR)
++ for i in $(I18Ndirs); do\
++ mkdir -p $(LOCALEDIR)/$$i/LC_MESSAGES;\
++ cp $(PODIR)/$$i.mo $(LOCALEDIR)/$$i/LC_MESSAGES/vdr-$(PLUGIN).mo;\
++ done
++
+ ### Targets:
+
+-all: libvdr-$(PLUGIN).so
++all: libvdr-$(PLUGIN).so i18n
+
+ libvdr-$(PLUGIN).so: $(SERVEROBJS) $(COMMONOBJS)
+
+@@ -106,6 +129,7 @@
+ @cp $@ $(LIBDIR)/$@.$(APIVERSION)
+
+ dist: clean
++ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+diff -Naur vdr-ffnetdev-0.1.2.orig/po/de_DE.po vdr-ffnetdev-0.1.2/po/de_DE.po
+--- vdr-ffnetdev-0.1.2.orig/po/de_DE.po 1970-01-01 01:00:00.000000000 +0100
++++ vdr-ffnetdev-0.1.2/po/de_DE.po 2012-10-31 18:38:02.000000000 +0100
+@@ -0,0 +1,30 @@
++# VDR plugin language source file.
++# Copyright (C) 2007 Klaus Schmidinger <kls@cadsoft.de>
++# This file is distributed under the same license as the VDR package.
++# Klaus Schmidinger <kls@cadsoft.de>, 2000
++# Erich Seifert <dev@erichseifert.de>, 2012
++#
++msgid ""
++msgstr ""
++"Project-Id-Version: VDR 1.7.27\n"
++"Report-Msgid-Bugs-To: dev@erichseifert.de\n"
++"POT-Creation-Date: 2012-10-30 14:31+0100\n"
++"PO-Revision-Date: 2012-10-30 14:37+0100\n"
++"Last-Translator: Klaus Schmidinger <kls@cadsoft.de>\n"
++"Language-Team: <vdr@linuxtv.org>\n"
++"Language: \n"
++"MIME-Version: 1.0\n"
++"Content-Type: text/plain; charset=ISO-8859-15\n"
++"Content-Transfer-Encoding: 8bit\n"
++
++#: ffnetdevsetup.c:18
++msgid "auto set as primary device"
++msgstr "Automatisch als prim�res Ger�t festlegen"
++
++#: ffnetdevsetup.c:18
++msgid "no"
++msgstr "nein"
++
++#: ffnetdevsetup.c:18
++msgid "yes"
++msgstr "ja"
diff --git a/media-plugins/vdr-ffnetdev/metadata.xml b/media-plugins/vdr-ffnetdev/metadata.xml
new file mode 100644
index 000000000000..7b3fdfd9ff6a
--- /dev/null
+++ b/media-plugins/vdr-ffnetdev/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <longdescription>VDR plugin to stream OSD Data in a Transport Stream (TS)</longdescription>
+</pkgmetadata>
diff --git a/media-plugins/vdr-ffnetdev/vdr-ffnetdev-0.1.2.ebuild b/media-plugins/vdr-ffnetdev/vdr-ffnetdev-0.1.2.ebuild
new file mode 100644
index 000000000000..36fbfcc2b193
--- /dev/null
+++ b/media-plugins/vdr-ffnetdev/vdr-ffnetdev-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+VERSION="837" # every bump, new version
+
+DESCRIPTION="VDR Plugin: Output device which offers OSD via VNC and Video as raw mpeg over network"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-ffnetdev"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P}
+
+DEPEND=">=media-video/vdr-1.6.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_gettext.diff"
+
+ vdr-plugin-2_src_prepare
+}