summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-lcr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-lcr')
-rw-r--r--media-plugins/vdr-lcr/Manifest1
-rw-r--r--media-plugins/vdr-lcr/metadata.xml15
-rw-r--r--media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild36
3 files changed, 52 insertions, 0 deletions
diff --git a/media-plugins/vdr-lcr/Manifest b/media-plugins/vdr-lcr/Manifest
new file mode 100644
index 000000000000..3496ced13144
--- /dev/null
+++ b/media-plugins/vdr-lcr/Manifest
@@ -0,0 +1 @@
+DIST vdr-lcr-0.0.9.tar.bz2 33314 SHA256 35a80d3662483fd2ed94ff5edb246dae4ac2e6b69bc03376028b3e19f9e0dd7c SHA512 b300f465b3b4fbd0cda33450f6408406d40a952d12fe7eb0fe9e5cd226765e79576550ee78b4c74030d4d32adfb70b2f05711dbae9e7070f9455c430b9c19582 WHIRLPOOL 5e34c65f2e2de30a9420344da4d951e3885e9b924eab6b3d58533381ee4301051cd95f1bcd49abd2d298fc81b365eda4471ea6b72909910034b7471e847873fa
diff --git a/media-plugins/vdr-lcr/metadata.xml b/media-plugins/vdr-lcr/metadata.xml
new file mode 100644
index 000000000000..0c60c8206fe4
--- /dev/null
+++ b/media-plugins/vdr-lcr/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ <description>
+ Please contacts maintainer before you something change.
+ </description>
+ </maintainer>
+ <longdescription>
+ Video Disk Recorder (VDR) Plugin to show best telefon tarif (LCR) on OSD
+ </longdescription>
+</pkgmetadata>
diff --git a/media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild b/media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild
new file mode 100644
index 000000000000..7f1cc4eea3e2
--- /dev/null
+++ b/media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: informe about Least Cost Routing (LCR)"
+HOMEPAGE="http://lcr.vdr-developer.org"
+SRC_URI="http://lcr.vdr-developer.org/downloads/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.5.7
+ >=dev-perl/libwww-perl-5.69-r2
+ >=dev-perl/HTML-Parser-3.34-r1
+ >=www-client/lynx-2.8.4"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ dobin contrib/vdr-lcr-retrieve_data.pl
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ echo
+ elog "By default, this plugin only supports the German telephone network"
+ elog "Find more info in /usr/bin/vdr-lcr-retrieve-data.pl how to add your"
+ elog "own Provider-Parser, or contact the maintainer"
+}