summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-music/vdr-music-0.9.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-music/vdr-music-0.9.9.ebuild')
-rw-r--r--media-plugins/vdr-music/vdr-music-0.9.9.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-plugins/vdr-music/vdr-music-0.9.9.ebuild b/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
new file mode 100644
index 000000000000..964ab2519252
--- /dev/null
+++ b/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+MY_P="${P}-dev2"
+S="${WORKDIR}/music-${PV}-dev2"
+
+DESCRIPTION="VDR plugin: music"
+HOMEPAGE="http://www.vdr.glaserei-franz.de/vdrplugins.htm"
+SRC_URI="http://www.glaserei-franz.de/VDR/Moronimo/files/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+imagemagick debug graphtft sndfile vorbis"
+
+DEPEND=">=media-video/vdr-1.6.0
+ media-libs/libmad
+ media-libs/libid3tag
+ graphtft? ( media-gfx/imagemagick[png] )
+ imagemagick? ( media-gfx/imagemagick[png] )
+ sndfile? ( media-libs/libsndfile )
+ vorbis? ( media-libs/libvorbis )
+ !imagemagick? (
+ !graphtft? ( media-libs/imlib2[png] )
+ )"
+
+RDEPEND="sys-process/at
+ media-sound/id3v2
+ graphtft? ( >=media-plugins/vdr-graphtft-0.1.5 )"
+
+src_prepare() {
+# # prepare sources with new Makefile handling
+# cp "${FILESDIR}/music.mk" "${S}"/Makefile
+
+ # clean up from untranslated .po files
+ rm "${S}"/po/{ca_ES,cs_CZ,da_DK,el_GR,es_ES,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,it_IT,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ vdr-plugin-2_src_prepare
+
+ use !vorbis && sed -i Makefile -e "s:#WITHOUT_LIBVORBISFILE=1:WITHOUT_LIBVORBISFILE=1:"
+ use !sndfile && sed -i Makefile -e "s:#WITHOUT_LIBSNDFILE=1:WITHOUT_LIBSNDFILE=1:"
+ use !debug && sed -i Makefile -e "s:DEBUG=1:#DEBUG=1:"
+ use graphtft || use imagemagick && sed -i Makefile \
+ -e "s:#HAVE_MAGICK=1:HAVE_MAGICK=1:" \
+ -e "s:#MAGICKDIR=:MAGICKDIR=:"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/music
+ doins -r moronsuite/music/*
+ chown -R vdr:vdr "${D}"/etc/vdr/plugins/music
+}