summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-02-20 21:57:39 +0100
committerSam James <sam@gentoo.org>2021-06-22 19:28:45 +0100
commit153c93a468550bca032e2d0bbe6169bf7d9b5c43 (patch)
tree53a0059e576f94a4c10967370abadf8204a9b5e9 /media-plugins/vdr-rssreader
parentvdr-plugin-2.eclass: fix pkgcheck findings in documentation (diff)
downloadgentoo-153c93a468550bca032e2d0bbe6169bf7d9b5c43.tar.gz
gentoo-153c93a468550bca032e2d0bbe6169bf7d9b5c43.tar.bz2
gentoo-153c93a468550bca032e2d0bbe6169bf7d9b5c43.zip
media-plugins/vdr-rssreader-2.2.1: update SRC_URI, new EAPI
plugin author moved to github adjust metadata.xml Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-rssreader')
-rw-r--r--media-plugins/vdr-rssreader/metadata.xml19
-rw-r--r--media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild35
2 files changed, 50 insertions, 4 deletions
diff --git a/media-plugins/vdr-rssreader/metadata.xml b/media-plugins/vdr-rssreader/metadata.xml
index 27f419c289c3..3044af88786f 100644
--- a/media-plugins/vdr-rssreader/metadata.xml
+++ b/media-plugins/vdr-rssreader/metadata.xml
@@ -1,8 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
-<email>vdr@gentoo.org</email>
-<name>Gentoo VDR Project</name>
-</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>martin.dummer@gmx.net</email>
+ <name>Martin Dummer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github"> rofafor/vdr-plugin-rssreader</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild b/media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..909b08861462
--- /dev/null
+++ b/media-plugins/vdr-rssreader/vdr-rssreader-2.2.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: RSS reader"
+HOMEPAGE="https://github.com/rofafor/vdr-plugin-rssreader"
+SRC_URI="https://github.com/rofafor/vdr-plugin-rssreader/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=media-video/vdr-2.2.0
+ >=dev-libs/expat-1.95.8
+ >=net-misc/curl-7.15.1-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-gentoo.diff"
+ "${FILESDIR}/${P}_c++11.patch"
+)
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-rssreader.*
+ usr/lib64/vdr/plugins/libvdr-rssreader.*"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/rssreader
+ doins "${S}/rssreader/rssreader.conf"
+}