summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild')
-rw-r--r--media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild b/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild
new file mode 100644
index 000000000000..b072c9c4955d
--- /dev/null
+++ b/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vdr-plugin-2
+
+VERSION="783" # changes with every version / new file :-(
+
+DESCRIPTION="VDR text2skin PlugIn"
+HOMEPAGE="http://projects.vdr-developer.org/projects/show/plg-text2skin"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="contrib doc +imagemagick imlib"
+
+REQUIRED_USE="imagemagick? ( !imlib )
+ imlib? ( !imagemagick )"
+
+RDEPEND=">=media-video/vdr-1.6.0
+ imagemagick? ( || ( media-gfx/imagemagick[cxx] media-gfx/graphicsmagick[cxx] ) )
+ imlib? ( media-libs/imlib2 >=media-video/vdr-1.6.0[-graphtft] )"
+DEPEND="${RDEPEND}
+ imagemagick? ( virtual/pkgconfig )
+ imlib? ( virtual/pkgconfig )
+ sys-devel/gettext"
+
+KEEP_I18NOBJECT="yes"
+
+src_prepare() {
+ local imagelib=
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+
+ sed -i common.c -e 's#cPlugin::ConfigDirectory(PLUGIN_NAME_I18N)#"/usr/share/vdr/"PLUGIN_NAME_I18N#'
+
+ if ! has_version ">=media-video/vdr-1.7.13"; then
+ sed -i "s:-include \$(VDRDIR)/Make.global:#-include \$(VDRDIR)/Make.global:" Makefile
+ fi
+
+ if use imagemagick; then
+ # Prefer imagemagick over graphicsmagick
+ if has_version "media-gfx/imagemagick"; then
+ imagelib="imagemagick"
+ elif has_version "media-gfx/graphicsmagick"; then
+ imagelib="graphicsmagick"
+ fi
+ elif use imlib; then
+ imagelib="imlib2"
+ else
+ imagelib="none"
+ fi
+ sed -i -e "s:\(IMAGELIB[[:space:]]*=\) .*:\1 ${imagelib}:" Makefile || die
+
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-1.7.27"; then
+ epatch "${FILESDIR}/vdr-1.7.27.diff"
+ fi
+
+ epatch "${FILESDIR}/${P}_vdr-2.1.2.diff"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ keepdir "/usr/share/vdr/${VDRPLUGIN}"
+
+ dodoc CONTRIBUTORS
+
+ if use doc; then
+ dodoc Docs/{Reference,Tutorial}.txt
+ fi
+
+ if use contrib; then
+ dodoc -r contrib/
+ fi
+}