summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2016-10-16 18:40:51 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2016-10-16 18:40:51 +0200
commit8eebc1f8da00f3b58e35c8334328155805bfaba9 (patch)
tree64a0b600ca292e6ed630a7b6f3feffcf40e9f6af /media-plugins/vdr-vcd
parentmedia-gfx/clockphoto: stable (diff)
downloadgentoo-8eebc1f8da00f3b58e35c8334328155805bfaba9.tar.gz
gentoo-8eebc1f8da00f3b58e35c8334328155805bfaba9.tar.bz2
gentoo-8eebc1f8da00f3b58e35c8334328155805bfaba9.zip
media-plugins/vdr-vcd: compilefix gcc-6; thx to P.Levine on wrt bug 594274
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-plugins/vdr-vcd')
-rw-r--r--media-plugins/vdr-vcd/files/vdr-vcd-0.9_gcc-6.patch24
-rw-r--r--media-plugins/vdr-vcd/vdr-vcd-0.9-r3.ebuild33
2 files changed, 57 insertions, 0 deletions
diff --git a/media-plugins/vdr-vcd/files/vdr-vcd-0.9_gcc-6.patch b/media-plugins/vdr-vcd/files/vdr-vcd-0.9_gcc-6.patch
new file mode 100644
index 000000000000..67d72fa83107
--- /dev/null
+++ b/media-plugins/vdr-vcd/files/vdr-vcd-0.9_gcc-6.patch
@@ -0,0 +1,24 @@
+compile fix gcc-6
+https://bugs.gentoo.org/show_bug.cgi?id=594274
+provided by P.Levine
+Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2016/Oct/16)
+--- vcd-0.9/functions.h.old 2016-09-23 23:59:29.151668778 -0400
++++ vcd-0.9/functions.h 2016-09-23 23:59:33.842225407 -0400
+@@ -167,7 +167,7 @@
+ __u16 playing_time;
+ __u8 play_item_wait_time;
+ __u8 auto_pause_wait_time;
+- __u16 play_item[];
++ __u16 play_item[1];
+ } play;
+ struct {
+ __u8 header;
+@@ -183,7 +183,7 @@
+ __u8 timeout_wait_time;
+ __u8 loop_count;
+ __u16 play_item;
+- __u16 selection_offset[];
++ __u16 selection_offset[1];
+ } selection;
+ };
+
diff --git a/media-plugins/vdr-vcd/vdr-vcd-0.9-r3.ebuild b/media-plugins/vdr-vcd/vdr-vcd-0.9-r3.ebuild
new file mode 100644
index 000000000000..a51db1b29d0a
--- /dev/null
+++ b/media-plugins/vdr-vcd/vdr-vcd-0.9-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: play video cds"
+
+HOMEPAGE="http://www.heiligenmann.de/"
+SRC_URI=" http://www.heiligenmann.de/vdr/download/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.5.9"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}_xgettext.diff"
+ "${FILESDIR}/${P}_vdr-1.7.2.diff"
+ "${FILESDIR}/${P}_devicetrickspeed.patch"
+ "${FILESDIR}/${P}_gcc-6.patch" )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # Patch Makefile, as VDRDIR is no well known variable name
+ # to stop spare -I in gcc cmdline
+ sed -e 's:$(VDRINC):$(VDRDIR)/include:' -i Makefile
+}