summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-xine/vdr-xine-0.9.4-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-xine/vdr-xine-0.9.4-r1.ebuild')
-rw-r--r--media-plugins/vdr-xine/vdr-xine-0.9.4-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-plugins/vdr-xine/vdr-xine-0.9.4-r1.ebuild b/media-plugins/vdr-xine/vdr-xine-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..8fb0e4c9e477
--- /dev/null
+++ b/media-plugins/vdr-xine/vdr-xine-0.9.4-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: for 'software only' playback using xine"
+HOMEPAGE="http://home.vr-web.de/~rnissl/"
+SRC_URI="http://home.vr-web.de/~rnissl/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="yaepg"
+
+COMMON_DEP=">=media-video/vdr-1.5.7
+ >=media-libs/xine-lib-1.1.8[vdr]"
+DEPEND="${COMMON_DEP}"
+RDEPEND="${COMMON_DEP}
+ >=media-video/mjpegtools-2.1.0
+ media-libs/netpbm"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-build-system.patch"
+
+ use yaepg && sed -i Makefile -e "s:#VDR_XINE_SET_VIDEO_WINDOW:VDR_XINE_SET_VIDEO_WINDOW:"
+
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-1.7.33"; then
+ sed -e "s:pid == patPmtParser.PmtPid():patPmtParser.IsPmtPid(pid):" \
+ -i xineDevice.c
+ fi
+
+ # remove i18n crap
+ sed -e "s:^#include[[:space:]]*\"xineI18n.h\"::" -i xine.c
+
+ BUILD_PARAMS="VDR_XINE_FIFO_DIR=/var/vdr/xine"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ dobin xineplayer || die
+
+ insinto /usr/share/vdr/xine
+ doins data/* || die
+
+ dodoc MANUAL
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ if [[ -d ${ROOT}/etc/vdr/plugins/xine ]]; then
+ ewarn "You have a leftover directory of vdr-xine."
+ ewarn "You can safely remove it with:"
+ ewarn "# rm -rf /etc/vdr/plugins/xine"
+ fi
+}