summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-03-24 21:23:13 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-03-24 21:23:13 +0100
commit00404d295fd74b2509002563d851c5e15d11213f (patch)
treea409d1de3ef2e126a4c3610bb1dcef6eb6820863 /media-plugins
parentdev-libs/libcgroup: fix build with slibtool (diff)
downloadgentoo-00404d295fd74b2509002563d851c5e15d11213f.tar.gz
gentoo-00404d295fd74b2509002563d851c5e15d11213f.tar.bz2
gentoo-00404d295fd74b2509002563d851c5e15d11213f.zip
media-plugins/vdr-graphlcd: llvm/clang compile fixed
Closes: https://bugs.gentoo.org/740296 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-graphlcd/vdr-graphlcd-1.0.1-r2.ebuild (renamed from media-plugins/vdr-graphlcd/vdr-graphlcd-1.0.1-r1.ebuild)14
1 files changed, 9 insertions, 5 deletions
diff --git a/media-plugins/vdr-graphlcd/vdr-graphlcd-1.0.1-r1.ebuild b/media-plugins/vdr-graphlcd/vdr-graphlcd-1.0.1-r2.ebuild
index bdaa50b4841d..d17c604261c5 100644
--- a/media-plugins/vdr-graphlcd/vdr-graphlcd-1.0.1-r1.ebuild
+++ b/media-plugins/vdr-graphlcd/vdr-graphlcd-1.0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,13 +45,17 @@ pkg_setup() {
src_prepare() {
vdr-plugin-2_src_prepare
- sed -i "s:/usr/local:/usr:" Makefile || die
- sed -i "s:i18n.c:i18n.h:g" Makefile || die
- sed -i "s:include \$(VDRDIR)/Make.global:-include \$(VDRDIR)/Make.global:" Makefile || die
+ sed -e "s:/usr/local:/usr:" \
+ -e "s:i18n.c:i18n.h:g" \
+ -e "s:include \$(VDRDIR)/Make.global:-include \$(VDRDIR)/Make.global:" \
+ -i Makefile || die
- sed -i "s:SKIP_INSTALL_DOC ?= 0:SKIP_INSTALL_DOC ?= 1:" Makefile || die
+ sed -e "s:SKIP_INSTALL_DOC ?= 0:SKIP_INSTALL_DOC ?= 1:" -i Makefile || die
eapply "${FILESDIR}/${P}_no-font.patch"
+
+ # bug 740296
+ sed -e "s:\"PLUGIN_GRAPHLCDCONF:\" PLUGIN_GRAPHLCDCONF:" -i plugin.c || die
}
src_install() {