summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilson Michaels <thebitpit@earthlink.net>2019-09-21 11:53:40 -0500
committerJoonas Niilola <juippis@gentoo.org>2019-11-18 08:14:14 +0200
commit33381f89cf2a48894b5fddab827d66e95a165a7f (patch)
treee42a253a481679b532f8bd636ccacd5ddffc5a2e /media-plugins
parentx11-misc/libinput-gestures: version bump to 2.48, sort revdep (diff)
downloadgentoo-33381f89cf2a48894b5fddab827d66e95a165a7f.tar.gz
gentoo-33381f89cf2a48894b5fddab827d66e95a165a7f.tar.bz2
gentoo-33381f89cf2a48894b5fddab827d66e95a165a7f.zip
media-plugins/mythplugins: new package - v. 30.0
Reviving package that previously was in gentoo with new version. Bug: https://bugs.gentoo.org/674216 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Wilson Michaels <thebitpit@earthlink.net> Closes: https://github.com/gentoo/gentoo/pull/13109 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythplugins/Manifest1
-rw-r--r--media-plugins/mythplugins/metadata.xml32
-rw-r--r--media-plugins/mythplugins/mythplugins-30.0.ebuild168
3 files changed, 201 insertions, 0 deletions
diff --git a/media-plugins/mythplugins/Manifest b/media-plugins/mythplugins/Manifest
new file mode 100644
index 000000000000..73e6f46179cc
--- /dev/null
+++ b/media-plugins/mythplugins/Manifest
@@ -0,0 +1 @@
+DIST mythplugins-30.0.tar.gz 101169041 BLAKE2B 0125c6234c168b9b24110b817e9e9a632187743c9ca44a46a8d464be6c330067f31da6fb252ed2a5fd770756229f2d95a746bd5d0e03be1e97fecc0de86603be SHA512 a29125ca33b1b100f51feb7a2ccff16d62928e474a393f11fc4b4fb77d0a85d9d4dd138acf757b527c0f936f3ff2e7d3eddcacef183d642429e36bc3e44ecbf4
diff --git a/media-plugins/mythplugins/metadata.xml b/media-plugins/mythplugins/metadata.xml
new file mode 100644
index 000000000000..3b81a44089c8
--- /dev/null
+++ b/media-plugins/mythplugins/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>thebitpit@earthlink.net</email>
+ <name>Wilson Michaels</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="cdr">Allows MythMusic to burn CD-Rs</flag>
+ <flag name="exif">Allows MythGallery to read EXIF data from photos</flag>
+ <flag name="fftw">Adds visual effects to MythMusic when playing back music</flag>
+ <flag name="hls">HTTP Live Streaming support</flag>
+ <flag name="raw">Allows MythGallery to view photos saved in RAW format</flag>
+ <flag name="mytharchive">Allows you to archive recorded content to CD or DVD</flag>
+ <flag name="mythbrowser">Adds a web browser within MythTV</flag>
+ <flag name="mythgallery">Adds a picture viewing gallery within MythTV</flag>
+ <flag name="mythgame">Adds a frontend to various ROM emulators within MythTV</flag>
+ <flag name="mythmusic">Adds the ability for MythTV to act as a music player</flag>
+ <flag name="mythnetvision">Adds the ability to view netvision devices within MythTV</flag>
+ <flag name="mythnews">Adds a news viewer within MythTV</flag>
+ <flag name="mythweather">Adds weather information within MythTV</flag>
+ <flag name="mythzmserver">Build mythzmserver daemon needed by zoneminder on LAN</flag>
+ <flag name="mythzoneminder">Adds support for zoneminder (requires active mythzmserver daemon on LAN).</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">MythTV/mythtv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-plugins/mythplugins/mythplugins-30.0.ebuild b/media-plugins/mythplugins/mythplugins-30.0.ebuild
new file mode 100644
index 000000000000..b574a2449e66
--- /dev/null
+++ b/media-plugins/mythplugins/mythplugins-30.0.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+BACKPORTS="03f44039848bd09444ff4baa8dc158bd61454079"
+MY_P=${P%_p*}
+
+inherit python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="Official WMythTV plugins"
+HOMEPAGE="https://www.mythtv.org"
+# mythtv and mythplugins are separate builds in the same github MythTV/mythtv repository
+SRC_URI="https://github.com/MythTV/mythtv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+MYTHPLUGINS="mytharchive +mythbrowser +mythgallery mythgame \
+mythmusic +mythnetvision +mythnews +mythweather mythzmserver mythzoneminder"
+IUSE="${MYTHPLUGINS} alsa cdda cdr exif fftw +hls ieee1394 libass +opengl raw +theora +vorbis +xml xvid"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ media-libs/freetype:2
+ media-libs/libpng:0=
+ sys-apps/util-linux
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ alsa? ( >=media-libs/alsa-lib-1.0.24 )
+ hls? (
+ media-libs/faac
+ media-libs/libvpx:=
+ >=media-libs/x264-0.0.20111220:=
+ >=media-sound/lame-3.93.1
+ )
+ ieee1394? (
+ >=media-libs/libiec61883-1.0.0
+ >=sys-libs/libavc1394-0.5.3
+ >=sys-libs/libraw1394-1.2.0
+ )
+ libass? ( >=media-libs/libass-0.9.11:= )
+ =media-tv/mythtv-${PV}*[alsa?,cdda?,cdr?,exif?,fftw?,ieee1394?,libass?,opengl?,python,raw?,xml?,xvid]
+ mytharchive? (
+ app-cdr/dvd+rw-tools
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-video/dvdauthor
+ media-video/mjpegtools[png]
+ media-video/transcode
+ virtual/cdrtools
+ )
+ mythbrowser? ( dev-qt/qtwebkit:5 )
+ mythgallery? (
+ media-libs/tiff:0
+ opengl? ( virtual/opengl:= )
+ exif? ( >media-libs/libexif-0.6.9:= )
+ raw? ( media-gfx/dcraw )
+ )
+ mythgame? ( sys-libs/zlib[minizip] )
+ mythmusic? (
+ >=media-libs/flac-1.1.2
+ media-libs/libogg
+ >=media-libs/libvorbis-1.0
+ >=media-libs/taglib-1.6
+ >=media-sound/lame-3.93.1
+ fftw? ( sci-libs/fftw:3.0= )
+ opengl? ( virtual/opengl )
+ cdda? (
+ dev-libs/libcdio:=
+ cdr? ( virtual/cdrtools )
+ )
+ )
+ mythnetvision? (
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mysql-python[${PYTHON_USEDEP}]
+ dev-python/oauth[${PYTHON_USEDEP}]
+ )
+ mythweather? (
+ dev-perl/Date-Manip
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath
+ dev-perl/DateTime
+ dev-perl/Image-Size
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/SOAP-Lite
+ dev-perl/JSON
+ )
+ mythzmserver? ( dev-db/mysql-connector-c:0/18 )
+ theora? ( media-libs/libtheora )
+ xml? ( >=dev-libs/libxml2-2.6.0:= )
+ xvid? ( >=media-libs/xvid-1.1.0 )
+"
+RDEPEND="${DEPEND}
+ !media-plugins/mytharchive
+ !media-plugins/mythbrowser
+ !media-plugins/mythgallery
+ !media-plugins/mythgame
+ !media-plugins/mythmovies
+ !media-plugins/mythmusic
+ !media-plugins/mythnetvision
+ !media-plugins/mythnews
+ !media-plugins/mythweather
+ !media-plugins/mythzmserver
+ !media-plugins/mythzoneminder
+"
+REQUIRED_USE="
+ mythmusic? ( vorbis )
+ mythnetvision? ( ${PYTHON_REQUIRED_USE} )
+ mythnews? ( mythbrowser )
+"
+
+# mythtv and mythplugins are separate builds in the same github MythTV/mythtv repository
+S="${WORKDIR}/mythtv-${PV}/mythplugins"
+
+DOC_CONTENTS="
+Common plugins are installed by default. Disable unneeded plugins individually with USE flags:
+-mythbrowser -mythgallery -mythmusic -mythnetvision -mythnews -mythweather
+Additional plugins may be installed with USE flags mytharchive mythgame mythzmserver mythzoneminder
+"
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ econf \
+ --python=${EPYTHON} \
+ --extra-ldflags="${LDFLAGS}" \
+ $(use_enable cdda cdio) \
+ $(use_enable exif) \
+ $(use_enable exif new-exif) \
+ $(use_enable fftw) \
+ $(use_enable opengl) \
+ $(use_enable raw dcraw) \
+ $(use_enable mytharchive) \
+ $(use_enable mythbrowser) \
+ $(use_enable mythgallery) \
+ $(use_enable mythgame) \
+ $(use_enable mythmusic) \
+ $(use_enable mythnetvision) \
+ $(use_enable mythnews) \
+ $(use_enable mythweather) \
+ $(use_enable mythzmserver) \
+ $(use_enable mythzoneminder)
+}
+
+src_install() {
+ emake STRIP="true" INSTALL_ROOT="${D}" install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}