summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-02 11:53:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-02 13:26:41 +0200
commit39c73ecc957243dfb048fd310225011956c7476e (patch)
tree06eb74b1c772795d5ad858e57039f9a27e2b4b4f /media-plugins
parentmedia-sound/audacious: Cleanup and sync live with 4.0.x (diff)
downloadgentoo-39c73ecc957243dfb048fd310225011956c7476e.tar.gz
gentoo-39c73ecc957243dfb048fd310225011956c7476e.tar.bz2
gentoo-39c73ecc957243dfb048fd310225011956c7476e.zip
media-plugins/audacious-plugins: Cleanup and sync live with 4.0.x
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-9999.ebuild39
-rw-r--r--media-plugins/audacious-plugins/metadata.xml1
2 files changed, 13 insertions, 27 deletions
diff --git a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
index f9b1ea0ec287..32544b9a66fb 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
@@ -17,14 +17,12 @@ HOMEPAGE="https://audacious-media-player.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="aac +alsa ampache bs2b cdda cue ffmpeg flac fluidsynth gme gtk http
- jack lame libav libnotify libsamplerate lirc mms modplug mp3 nls opengl
- pulseaudio qtmedia scrobbler sdl sid sndfile soxr speedpitch streamtuner
- vorbis wavpack"
+IUSE="aac +alsa ampache bs2b cdda cue ffmpeg flac fluidsynth gme http jack lame
+ libnotify libsamplerate lirc mms modplug mp3 nls opengl pulseaudio qtmedia
+ scrobbler sdl sid sndfile soxr speedpitch streamtuner vorbis wavpack"
REQUIRED_USE="
|| ( alsa jack pulseaudio qtmedia sdl )
- ampache? ( http ) streamtuner? ( http )
- gtk? ( !ampache !qtmedia !streamtuner )"
+ ampache? ( http ) streamtuner? ( http )"
# The following plugins REQUIRE a GUI build of audacious, because non-GUI
# builds do NOT install the libaudgui library & headers.
@@ -53,7 +51,10 @@ DEPEND="
dev-libs/dbus-glib
dev-libs/glib
dev-libs/libxml2:2
- ~media-sound/audacious-${PV}[gtk=]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ ~media-sound/audacious-${PV}
aac? ( >=media-libs/faad2-2.7 )
alsa? ( >=media-libs/alsa-lib-1.0.16 )
ampache? ( =media-libs/ampache_browser-1* )
@@ -70,17 +71,6 @@ DEPEND="
>=media-libs/libvorbis-1.0
)
fluidsynth? ( media-sound/fluidsynth:= )
- gtk? (
- x11-libs/gtk+:2
- x11-libs/libXcomposite
- x11-libs/libXrender
- )
- !gtk? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- opengl? ( dev-qt/qtopengl:5 )
- )
http? ( >=net-libs/neon-0.26.4 )
jack? (
>=media-libs/bio2jack-0.4
@@ -93,6 +83,7 @@ DEPEND="
mms? ( >=media-libs/libmms-0.3 )
modplug? ( media-libs/libmodplug )
mp3? ( >=media-sound/mpg123-1.12.1 )
+ opengl? ( dev-qt/qtopengl:5 )
pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
qtmedia? ( dev-qt/qtmultimedia:5 )
scrobbler? ( net-misc/curl )
@@ -127,8 +118,10 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--enable-mpris2
+ --enable-qt
--enable-songchange
--disable-adplug # not packaged
+ --disable-gtk
--disable-openmpt # not packaged
--disable-oss4
--disable-coreaudio
@@ -143,10 +136,6 @@ src_configure() {
$(use_enable flac filewriter)
$(use_enable fluidsynth amidiplug)
$(use_enable gme console)
- $(use_enable gtk aosd)
- $(use_enable gtk gtk)
- $(use_enable gtk hotkey)
- $(use_enable !gtk qt)
$(use_enable http neon)
$(use_enable jack)
$(use_enable lame filewriter_mp3)
@@ -157,6 +146,7 @@ src_configure() {
$(use_enable modplug)
$(use_enable mp3 mpg123)
$(use_enable nls)
+ $(use_enable opengl qtglspectrum)
$(use_enable pulseaudio pulse)
$(use_enable qtmedia qtaudio)
$(use_enable scrobbler scrobbler2)
@@ -168,10 +158,7 @@ src_configure() {
$(use_enable streamtuner)
$(use_enable vorbis)
$(use_enable wavpack)
- $(use_with ffmpeg ffmpeg $(usex libav libav ffmpeg))
- )
- use !gtk && myeconfargs+=(
- $(usex opengl --enable-qtglspectrum --disable-qtglspectrum)
+ $(use_with ffmpeg ffmpeg ffmpeg)
)
econf "${myeconfargs[@]}"
diff --git a/media-plugins/audacious-plugins/metadata.xml b/media-plugins/audacious-plugins/metadata.xml
index 02bd0208b848..30eb5c5c92d9 100644
--- a/media-plugins/audacious-plugins/metadata.xml
+++ b/media-plugins/audacious-plugins/metadata.xml
@@ -15,7 +15,6 @@
<flag name="cue">Support CUE sheets using the libcue library</flag>
<flag name="fluidsynth">Support FluidSynth as MIDI synth backend</flag>
<flag name="gme">Support various gaming console music formats</flag>
- <flag name="gtk">Build with GTK interface instead of Qt5</flag>
<flag name="http">Support HTTP streams through neon</flag>
<flag name="qtmedia">Enable playback via <pkg>dev-qt/qtmultimedia</pkg></flag>
<flag name="scrobbler">Build with scrobbler/LastFM submission support</flag>