summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-01-23 16:48:04 -0500
committerCraig Andrews <candrews@gentoo.org>2021-01-23 16:48:52 -0500
commit60c80f34e08c6ec3cfc5c7d5d4b06c9e7f594d9a (patch)
treef8a7f37da96cd281fa568d1a31c7a55a24b22b55 /media-plugins
parentmedia-libs/sdl2-gfx: Fixed build with sys-devel/slibtool (diff)
downloadgentoo-60c80f34e08c6ec3cfc5c7d5d4b06c9e7f594d9a.tar.gz
gentoo-60c80f34e08c6ec3cfc5c7d5d4b06c9e7f594d9a.tar.bz2
gentoo-60c80f34e08c6ec3cfc5c7d5d4b06c9e7f594d9a.zip
media-plugins/kodi-pvr-nextpvr: 8.2.0 version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-pvr-nextpvr/Manifest1
-rw-r--r--media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-8.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-nextpvr/Manifest b/media-plugins/kodi-pvr-nextpvr/Manifest
index 635407971cc9..92919ec6a9ac 100644
--- a/media-plugins/kodi-pvr-nextpvr/Manifest
+++ b/media-plugins/kodi-pvr-nextpvr/Manifest
@@ -1 +1,2 @@
DIST kodi-pvr-nextpvr-8.0.3.tar.gz 149416 BLAKE2B 8a73f70dbca1427dc73d048e26da61e47c254834be04b93998358c25ad99a4d82307bd3cdc0d5d8055708572434a862c26c3d1f4cdb3aecd6886729a2cfafcdb SHA512 9a9cb89d80d39314d86d1412cc50d86411099e1a94ab32d51927bbba729e4e2312c8183505758eb1da402914d7e774b118154aded07e40e8abf6f2ccc187010c
+DIST kodi-pvr-nextpvr-8.2.0.tar.gz 150040 BLAKE2B aa72f4c830f2a64a5f94ea636a518de1f6f84a4503aa15154c5f5d58189cb6e4dfb9f9051f187e5655ca9533718e334a50c325802cbd93e6827a48b43ee09af9 SHA512 f86b7f9462a6fa52d6457581152b5639c7603860e85158aa1f930a19912e5fdb91a0cc6dccd2bd1ac5e1524046a7dd4bf8387aaef30f7366f3bb2db99b82f9a1
diff --git a/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-8.2.0.ebuild b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-8.2.0.ebuild
new file mode 100644
index 000000000000..f1d5484de0ab
--- /dev/null
+++ b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-8.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Kodi's NextPVR client addon"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.nextpvr"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.nextpvr.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.nextpvr/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.nextpvr-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ dev-libs/tinyxml2
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "