summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-28 10:43:52 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-28 10:52:27 -0400
commit8ee6188255f0be5fe4f7733da04d3d063a1262f1 (patch)
tree42138843b5d489a595bec3723886503af046ed76 /media-plugins
parentmedia-plugins/kodi-game-libretro: 1.1.1 version bump (diff)
downloadgentoo-8ee6188255f0be5fe4f7733da04d3d063a1262f1.tar.gz
gentoo-8ee6188255f0be5fe4f7733da04d3d063a1262f1.tar.bz2
gentoo-8ee6188255f0be5fe4f7733da04d3d063a1262f1.zip
media-plugins/kodi-vfs-sftp: 1.0.3 version bump
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-vfs-sftp/Manifest1
-rw-r--r--media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-1.0.3.ebuild40
-rw-r--r--media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild5
3 files changed, 46 insertions, 0 deletions
diff --git a/media-plugins/kodi-vfs-sftp/Manifest b/media-plugins/kodi-vfs-sftp/Manifest
index b07f32bc75d6..8030e5ccfdf1 100644
--- a/media-plugins/kodi-vfs-sftp/Manifest
+++ b/media-plugins/kodi-vfs-sftp/Manifest
@@ -1 +1,2 @@
DIST kodi-vfs-sftp-1.0.1.tar.gz 20059 BLAKE2B 3ff2178738dbb85de731d5268d80cad079f684234ff39ca1141337c384377ca75dd5ad51026471af4e8a1229c6739fa9212b6fd6253cad9be6d9b19a7dc7081a SHA512 e51aeae2bf6e611e679b38401add778fc5605ededb8b8b9d2f6732eda4b87fdee5ea352d2c491cf1ff671c0299395de1cc689404e2924266ffef84c4e7cc71c3
+DIST kodi-vfs-sftp-1.0.3.tar.gz 20923 BLAKE2B 3f2856fa97453739d6a712b5ce63d97771d4f763e182ba28c311a1d5add1f9aae14d069cbcccebeec116a0c138bfbb545aadb1657bb712559d8c73406d61dc4e SHA512 2d0b1f21e3815780124013456abfc4ba07f6a26a3406ba65db76e197254a068a6bfbbe5deb6fb264cbaabe83ac8301a6a7f5f668790934dc7c727745472a3764
diff --git a/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-1.0.3.ebuild b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-1.0.3.ebuild
new file mode 100644
index 000000000000..0c002b5c684f
--- /dev/null
+++ b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-1.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="SFTP VFS addon for Kodi"
+HOMEPAGE="https://github.com/xbmc/vfs.sftp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/xbmc/vfs.sftp.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/xbmc/vfs.sftp/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vfs.sftp-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ net-libs/libssh[sftp]
+ =media-libs/kodi-platform-18*
+ =media-tv/kodi-18*
+ "
+
+src_prepare(){
+ [ -d depends ] && rm -rf depends || die
+ cmake-utils_src_prepare
+}
diff --git a/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
index aa38c3ff2d60..3b97cecb2fba 100644
--- a/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
+++ b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
@@ -33,3 +33,8 @@ DEPEND="
~media-libs/kodi-platform-9999
~media-tv/kodi-9999
"
+
+src_prepare(){
+ [ -d depends ] && rm -rf depends || die
+ cmake-utils_src_prepare
+}