summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-14 21:29:00 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-15 19:04:46 -0400
commitd0ae8ecc4501ce09859ac41aad7a1ba355b7103b (patch)
tree0e85f4cb791fa79cb3ddb532483b4118c9b88206 /media-plugins
parentmedia-libs/grilo: Version bump to 0.3.13 (diff)
downloadgentoo-d0ae8ecc4501ce09859ac41aad7a1ba355b7103b.tar.gz
gentoo-d0ae8ecc4501ce09859ac41aad7a1ba355b7103b.tar.bz2
gentoo-d0ae8ecc4501ce09859ac41aad7a1ba355b7103b.zip
media-plugins/grilo-plugins: Version bump to 0.3.13
* Port to lua-single eclass Closes: https://bugs.gentoo.org/752756 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/grilo-plugins/Manifest1
-rw-r--r--media-plugins/grilo-plugins/files/0.3.13-meson-goa.patch49
-rw-r--r--media-plugins/grilo-plugins/files/0.3.13-meson-tracker3-test.patch29
-rw-r--r--media-plugins/grilo-plugins/grilo-plugins-0.3.13.ebuild113
4 files changed, 192 insertions, 0 deletions
diff --git a/media-plugins/grilo-plugins/Manifest b/media-plugins/grilo-plugins/Manifest
index ff149a7c2189..7f308a9c39be 100644
--- a/media-plugins/grilo-plugins/Manifest
+++ b/media-plugins/grilo-plugins/Manifest
@@ -1 +1,2 @@
DIST grilo-plugins-0.3.11.tar.xz 1449408 BLAKE2B 8ed9bd49f779eadb486a13be3bbdee0df797ebffb7833eaf2632cbb6fac90b33e2f3c92223c7e6d268257aabd710e0b9fd6c8e9395bfae776990a64e7537b41a SHA512 eefeabf333568d06ce77ba865f2dc96592428ae41c459f51e2ea7f37914c2b3d52778e5548b7d49059f1e4b83c8c07e5a8798272c5ced0259de1900d9e3f6991
+DIST grilo-plugins-0.3.13.tar.xz 1835320 BLAKE2B 3c39c652700eba0d6c557dbfa700a4f8f1b52ecadb757d7c36b5a3023f096fcb7587f4b054f75eb12ffee61b423abbca73d7847d902450d23b5527024f260058 SHA512 7edccc7366623c3dab56f7c95156327db08efdf038563c9be3e423c517a1117003ef516a069f9a2e877f6a610dad6783d3087d111b039ce7bdc6657124cf8e25
diff --git a/media-plugins/grilo-plugins/files/0.3.13-meson-goa.patch b/media-plugins/grilo-plugins/files/0.3.13-meson-goa.patch
new file mode 100644
index 000000000000..8122e57db3fd
--- /dev/null
+++ b/media-plugins/grilo-plugins/files/0.3.13-meson-goa.patch
@@ -0,0 +1,49 @@
+https://gitlab.gnome.org/GNOME/grilo-plugins/-/merge_requests/109
+
+From 27585cd5bcfba9e75d8ca9bc86dc0b7b3e5a2e59 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 16 Feb 2019 14:44:44 +0200
+Subject: [PATCH] build: Support controlling gnome-online-accounts dep
+
+On Gentoo, some users prefer to disable gnome-online-accounts since it
+brings in the large WebKitGTK dependency.
+---
+ meson.build | 4 ++--
+ meson_options.txt | 1 +
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 74a5d2a9..5f8c7cd4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -13,7 +13,7 @@ project('grilo-plugins', 'c',
+ 'warning_level=1'
+ ],
+ license: 'LGPL 2.1',
+- meson_version: '>= 0.44.0')
++ meson_version: '>= 0.47.0')
+
+ plugin_version = meson.project_version()
+ version_array = plugin_version.split('.')
+@@ -52,7 +52,7 @@ avahi_glib_dep = dependency('avahi-glib', required: false)
+ avahi_gobject_dep = dependency('avahi-gobject', required: false)
+ gio_dep = dependency('gio-2.0', required: false)
+ gio_unix_dep = dependency('gio-unix-2.0', required: false)
+-goa_dep = dependency('goa-1.0', version: '>= 3.17.91', required: false)
++goa_dep = dependency('goa-1.0', version: '>= 3.17.91', required: get_option('goa'))
+ gom_dep = dependency('gom-1.0', version: '>= 0.4', required: false)
+ grilo_net_dep = dependency('grilo-net-0.3', version: '>= 0.3.0', required: false,
+ fallback: ['grilo', 'libgrlnet_dep'])
+diff --git a/meson_options.txt b/meson_options.txt
+index f5132228..1e0ea090 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -21,4 +21,5 @@ option('enable-tmdb', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'a
+ option('enable-tracker', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'auto', description: 'Enable Tracker plugin (DEPRECATED)')
+ option('enable-tracker3', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'auto', description: 'Enable Tracker3 plugin')
+ option('enable-youtube', type: 'combo', choices: [ 'auto', 'yes', 'no' ], value: 'auto', description: 'Enable YouTube plugin')
++option('goa', type: 'feature', value: 'auto', description: 'Enable gnome-online-accounts usage')
+ option('help', type: 'combo', choices: [ 'yes', 'no' ], value: 'yes', description: 'Build examples developers')
+--
+2.26.3
+
diff --git a/media-plugins/grilo-plugins/files/0.3.13-meson-tracker3-test.patch b/media-plugins/grilo-plugins/files/0.3.13-meson-tracker3-test.patch
new file mode 100644
index 000000000000..0812d7936b6d
--- /dev/null
+++ b/media-plugins/grilo-plugins/files/0.3.13-meson-tracker3-test.patch
@@ -0,0 +1,29 @@
+https://gitlab.gnome.org/GNOME/grilo-plugins/-/merge_requests/110
+
+From 62229a03614add0d3cb6e1087f241407f952de12 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Wed, 14 Apr 2021 22:08:13 -0400
+Subject: [PATCH] build: Only run tracker3 test when enabled
+
+Previously -Denable-tracker3=no would not build the tracker3 plugin but
+if the dependency was found on the system the unit test would still be
+enabled (and would fail).
+---
+ tests/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 97e196db..7ba2236b 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -39,6 +39,6 @@ if local_metadata_enabled and lua_factory_enabled
+ subdir('local-metadata')
+ endif
+
+-if tracker3_dep.found() and tracker3_testutils_dep.found()
++if get_option('enable-tracker3') != 'no' and tracker3_dep.found() and tracker3_testutils_dep.found()
+ subdir('tracker3')
+ endif
+--
+2.26.3
+
diff --git a/media-plugins/grilo-plugins/grilo-plugins-0.3.13.ebuild b/media-plugins/grilo-plugins/grilo-plugins-0.3.13.ebuild
new file mode 100644
index 000000000000..b1aa867de4f8
--- /dev/null
+++ b/media-plugins/grilo-plugins/grilo-plugins-0.3.13.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+LUA_COMPAT=( lua5-3 )
+inherit gnome.org lua-single meson xdg
+
+DESCRIPTION="A collection of plugins for the Grilo framework"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="daap chromaprint flickr freebox gnome-online-accounts lua test thetvdb tracker upnp-av +youtube"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+# GOA is only optionally used by flickr and lua-factory plugins (checked at v0.3.13)
+# json-glib used by tmdb and lua; tmdb currently non-optional
+# TODO: validate upnp-av dleyna deps
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=media-libs/grilo-0.3.13:${SLOT}=[playlist]
+ freebox? ( net-dns/avahi[dbus] )
+ >=dev-libs/gom-0.4
+ chromaprint? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-plugins/gst-plugins-chromaprint:1.0
+ )
+ dev-libs/json-glib
+ daap? ( >=net-libs/libdmapsharing-2.9.12:3.0 )
+ media-libs/libmediaart:2.0
+ net-libs/libsoup:2.4
+ dev-libs/libxml2:2
+ flickr? (
+ net-libs/liboauth
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.91:= )
+ )
+ dev-db/sqlite:3
+ >=dev-libs/totem-pl-parser-3.4.1
+ tracker? ( app-misc/tracker:3= )
+ upnp-av? (
+ net-libs/dleyna-connector-dbus
+ net-misc/dleyna-server
+ )
+ lua? (
+ ${LUA_DEPS}
+ app-arch/libarchive
+ dev-libs/libxml2:2
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.91:= )
+ )
+ thetvdb? ( app-arch/libarchive )
+ youtube? ( >=dev-libs/libgdata-0.9.1:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ upnp-av? ( >=dev-util/gdbus-codegen-2.44 )
+ virtual/pkgconfig
+ lua? ( dev-util/gperf )
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.3.13-meson-goa.patch
+ "${FILESDIR}"/0.3.13-meson-tracker3-test.patch
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+ sed -i -e "s:'GETTEXT_PACKAGE', meson.project_name():'GETTEXT_PACKAGE', 'grilo-plugins-${SLOT%/*}':" meson.build || die
+ sed -i -e "s:meson.project_name():'grilo-plugins-${SLOT%/*}':" po/meson.build || die
+ sed -i -e "s:meson.project_name():'grilo-plugins-${SLOT%/*}':" help/meson.build || die
+
+ # libdmapsharing-4 is not packaged
+ sed -i -e "s:libdmapsharing4_dep.found():false:" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable-bookmarks=yes
+ -Denable-chromaprint=$(usex chromaprint yes no)
+ -Denable-dleyna=$(usex upnp-av yes no)
+ -Denable-dmap=$(usex daap yes no)
+ -Denable-filesystem=yes
+ -Denable-flickr=$(usex flickr yes no)
+ -Denable-freebox=$(usex freebox yes no)
+ -Denable-gravatar=yes
+ -Denable-local-metadata=yes
+ -Denable-lua-factory=$(usex lua yes no)
+ -Denable-magnatune=yes
+ -Denable-metadata-store=yes
+ -Denable-opensubtitles=yes
+ -Denable-optical-media=yes
+ -Denable-podcasts=yes
+ -Denable-raitv=yes
+ -Denable-shoutcast=yes
+ -Denable-thetvdb=$(usex thetvdb yes no)
+ -Denable-tmdb=yes
+ -Denable-tracker=no
+ -Denable-tracker3=$(usex tracker yes no)
+ -Denable-youtube=$(usex youtube yes no)
+ $(meson_feature gnome-online-accounts goa)
+ -Dhelp=no
+ )
+ meson_src_configure
+}