summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-02-19 08:39:22 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-02-19 08:39:32 +0100
commitd4de80cbe3153f9f25480432eb7683a1983b0794 (patch)
tree1619635bfc693306969b904ce9424df92805630d /media-plugins
parentdev-perl/YAML-PP: Stabilize 0.30.0 ppc, #833684 (diff)
downloadgentoo-d4de80cbe3153f9f25480432eb7683a1983b0794.tar.gz
gentoo-d4de80cbe3153f9f25480432eb7683a1983b0794.tar.bz2
gentoo-d4de80cbe3153f9f25480432eb7683a1983b0794.zip
media-plugins/x42-plugins: don't call cc directly
Closes: https://bugs.gentoo.org/809047 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/x42-plugins/x42-plugins-20211016.ebuild6
-rw-r--r--media-plugins/x42-plugins/x42-plugins-20220107.ebuild4
-rw-r--r--media-plugins/x42-plugins/x42-plugins-99999999.ebuild4
3 files changed, 10 insertions, 4 deletions
diff --git a/media-plugins/x42-plugins/x42-plugins-20211016.ebuild b/media-plugins/x42-plugins/x42-plugins-20211016.ebuild
index 1902a6a9dea8..f21f833fe408 100644
--- a/media-plugins/x42-plugins/x42-plugins-20211016.ebuild
+++ b/media-plugins/x42-plugins/x42-plugins-20211016.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Collection of LV2 plugins"
HOMEPAGE="https://github.com/x42/x42-plugins"
@@ -38,7 +40,7 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
src_compile() {
- emake STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
+ emake CC="$(tc-getCC)" STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
}
src_install() {
diff --git a/media-plugins/x42-plugins/x42-plugins-20220107.ebuild b/media-plugins/x42-plugins/x42-plugins-20220107.ebuild
index 324e65350f3f..2ee199d0ef8f 100644
--- a/media-plugins/x42-plugins/x42-plugins-20220107.ebuild
+++ b/media-plugins/x42-plugins/x42-plugins-20220107.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit toolchain-funcs
+
DESCRIPTION="Collection of LV2 plugins"
HOMEPAGE="https://github.com/x42/x42-plugins"
@@ -38,7 +40,7 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
src_compile() {
- emake STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
+ emake CC="$(tc-getCC)" STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
}
src_install() {
diff --git a/media-plugins/x42-plugins/x42-plugins-99999999.ebuild b/media-plugins/x42-plugins/x42-plugins-99999999.ebuild
index 324e65350f3f..2ee199d0ef8f 100644
--- a/media-plugins/x42-plugins/x42-plugins-99999999.ebuild
+++ b/media-plugins/x42-plugins/x42-plugins-99999999.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit toolchain-funcs
+
DESCRIPTION="Collection of LV2 plugins"
HOMEPAGE="https://github.com/x42/x42-plugins"
@@ -38,7 +40,7 @@ DEPEND="${RDEPEND}
sys-apps/help2man"
src_compile() {
- emake STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
+ emake CC="$(tc-getCC)" STRIP="#" FONTFILE="/usr/share/fonts/dejavu/DejaVuSans-Bold.ttf"
}
src_install() {