summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2019-11-09 08:53:35 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-25 19:52:42 +0100
commitfdd4da47b56b167fa989bdbb3b50146c32b4d97d (patch)
treefe094f86a3a2da8507df1b2dd505fbe867aec9d9 /media-plugins
parentnet-proxy/haproxy: Security bumps (diff)
downloadgentoo-fdd4da47b56b167fa989bdbb3b50146c32b4d97d.tar.gz
gentoo-fdd4da47b56b167fa989bdbb3b50146c32b4d97d.tar.bz2
gentoo-fdd4da47b56b167fa989bdbb3b50146c32b4d97d.zip
media-plugins/vdr-osdteletext: bump to version 0.9.7
vdr-osdteletext-0.9.7 is needed for >media-video/vdr-2.3 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/13590 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-osdteletext/Manifest1
-rw-r--r--media-plugins/vdr-osdteletext/metadata.xml11
-rw-r--r--media-plugins/vdr-osdteletext/vdr-osdteletext-0.9.7.ebuild47
3 files changed, 56 insertions, 3 deletions
diff --git a/media-plugins/vdr-osdteletext/Manifest b/media-plugins/vdr-osdteletext/Manifest
index 2264d9d31b9a..643c7c702103 100644
--- a/media-plugins/vdr-osdteletext/Manifest
+++ b/media-plugins/vdr-osdteletext/Manifest
@@ -1,2 +1,3 @@
DIST vdr-osdteletext-0.9.4.tgz 62971 BLAKE2B e4d1223522709c0aca5fe3a11065575fac0860caac1eb31443461c2f9b5b7a186d969e8827e73470208ae7ff91ed16c83cbd2efce0d6690109ddb2f8a20723fc SHA512 fe688f7dfddf5d5f270dcf7c2b4d3ab70cee68d0f75e0d283479d5c84217a17f4f1d638e764adaa6e3bbffd4e4a7f8bd1b55c6ab2847592b0a3ad27ffad50dbe
DIST vdr-osdteletext-0.9.5.tgz 62692 BLAKE2B fcccb186c4db1485217ac427c79903e76e04b63d561977e79ae61b389cf17e2252e107ed2901a5a72851101b18a392faf4f9d12660b44a7eb8784e223e9fce4c SHA512 cb75189c1065fb53b99fd684e7fcc3d373a799fd77965780fdb36dc0c2458e5c94896bf6516451f1a038d3bf7bf7cc962f3a3d53be4f0c43c41acda6267bbcaf
+DIST vdr-osdteletext-0.9.7.tgz 101400 BLAKE2B 52cabda446701ce4898705487e47e5ca5146e58b42b47814f3835326c72118c62212ab81cad036f147e23b0c330b08bd2b2ba82bb7cc41f1bfcbd2525dbfe179 SHA512 d7ebd74ba5411bc8c7596b4f5f30eba7bc71e09d137a10650e78761c58045a96f804468f87fbf0c27e8fa161b64b06035878e5fac9940f75ea728646e92e6c76
diff --git a/media-plugins/vdr-osdteletext/metadata.xml b/media-plugins/vdr-osdteletext/metadata.xml
index ec9a9c10e83e..3e9db7f63bd7 100644
--- a/media-plugins/vdr-osdteletext/metadata.xml
+++ b/media-plugins/vdr-osdteletext/metadata.xml
@@ -1,12 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>martin.dummer@gmx.net</email>
+ <name>Martin Dummer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<maintainer type="project">
<email>vdr@gentoo.org</email>
<name>Gentoo VDR Project</name>
- <description>
- Please contact maintainer before you change something.
- </description>
</maintainer>
<longdescription>
VDR Plugin to show videotext on OSD
diff --git a/media-plugins/vdr-osdteletext/vdr-osdteletext-0.9.7.ebuild b/media-plugins/vdr-osdteletext/vdr-osdteletext-0.9.7.ebuild
new file mode 100644
index 000000000000..8e3fb41150ac
--- /dev/null
+++ b/media-plugins/vdr-osdteletext/vdr-osdteletext-0.9.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+VERSION="2161" # every bump, new version
+
+DESCRIPTION="VDR Plugin: Osd-Teletext displays the teletext on the OSD"
+HOMEPAGE="https://projects.vdr-developer.org/projects/plg-osdteletext"
+SRC_URI="https://projects.vdr-developer.org/attachments/download/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-video/vdr"
+RDEPEND="${DEPEND}"
+
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-v3.sh"
+VDR_CONFD_FILE="${FILESDIR}/confd-v2"
+
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-.*
+ usr/lib64/vdr/plugins/libvdr-.*"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/sudoers.d
+ insopts -m440
+ newins "${FILESDIR}/vdr-osdteletext.sudo" vdr-osdteletext
+
+ local vdr_user_home="/var/vdr"
+ insinto "${vdr_user_home}/.local/share/fonts/"
+ insopts -m444
+ doins teletext2.ttf
+ fowners -R vdr:vdr "${vdr_user_home}/.local"
+}
+
+pkg_postinst() {
+ elog "This ebuild has installed a special teletext font"
+ elog "named \"teletext2\""
+ elog "You may go to the plugin's setup menu and select"
+ elog "the font."
+}