summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:13:24 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:19 +0000
commitd395bde2f5229da8bb5835fcc1f1c2ea202adfdd (patch)
tree92d9acd803760909cd877bc4b0e899e02537a42e /media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
parentmedia-plugins/vdr-xineliboutput: call pkg-config via toolchain-funcs.eclass h... (diff)
downloadgentoo-d395bde2f5229da8bb5835fcc1f1c2ea202adfdd.tar.gz
gentoo-d395bde2f5229da8bb5835fcc1f1c2ea202adfdd.tar.bz2
gentoo-d395bde2f5229da8bb5835fcc1f1c2ea202adfdd.zip
media-radio/fsync-mdc1200-decode: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild')
-rw-r--r--media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
index a452f7447737..2316114ab76b 100644
--- a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
+++ b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,7 +26,7 @@ RDEPEND="${DEPEND}"
BDEPEND=""
src_compile() {
- $(tc-getCC) -o fsync-mdc1200-decode ${CFLAGS} ${LDFLAGS} demod.c fsync_decode.c mdc_decode.c $(pkg-config --cflags --libs libpulse-simple)
+ $(tc-getCC) -o fsync-mdc1200-decode ${CFLAGS} ${LDFLAGS} demod.c fsync_decode.c mdc_decode.c $($(tc-getPKG_CONFIG) --cflags --libs libpulse-simple)
}
src_install() {