summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2019-12-22 21:39:09 -0500
committerRichard Freeman <rich0@gentoo.org>2019-12-22 21:39:30 -0500
commitf1daa4d7f4e7b3965086d3826d84a8bef483c3c2 (patch)
tree619b9b81798cda66bd4044a52b7214bc8cd837d7 /media-radio/js8call/js8call-2.1.0.ebuild
parentsci-libs/tensorflow: bump 2.1.0_rc1 (diff)
downloadgentoo-f1daa4d7f4e7b3965086d3826d84a8bef483c3c2.tar.gz
gentoo-f1daa4d7f4e7b3965086d3826d84a8bef483c3c2.tar.bz2
gentoo-f1daa4d7f4e7b3965086d3826d84a8bef483c3c2.zip
media-radio/js8call: bump
Requires patch for current release hamlib. May need to revist for hamlib-3.4. Dep adjusted anticipating this until the new version can be released. Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'media-radio/js8call/js8call-2.1.0.ebuild')
-rw-r--r--media-radio/js8call/js8call-2.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-radio/js8call/js8call-2.1.0.ebuild b/media-radio/js8call/js8call-2.1.0.ebuild
new file mode 100644
index 000000000000..d886436dd36d
--- /dev/null
+++ b/media-radio/js8call/js8call-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils vcs-snapshot
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Weak signal ham radio communication"
+HOMEPAGE="https://groups.io/g/js8call"
+SRC_URI="https://bitbucket.org/widefido/js8call/get/v${PV}-ga.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtserialport:5
+ dev-qt/qtprintsupport:5
+ virtual/libusb:1
+ media-libs/portaudio
+ sci-libs/fftw:3.0[threads,fortran]
+ virtual/fortran
+ app-text/asciidoc
+ <media-libs/hamlib-3.4
+ doc? ( dev-ruby/asciidoctor )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-hamlib-type.patch" )
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/bin/rigctl{,d}-local || die
+ rm "${D}"/usr/share/doc/JS8Call -R || die
+}