summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2018-11-05 21:36:39 -0500
committerRichard Freeman <rich0@gentoo.org>2018-11-05 21:36:55 -0500
commitfb97d8a117f429baf36f1a4abd99ab091a008894 (patch)
tree2b5b3397de37941ed765a700ab0e7cfe94b99ebe /media-radio/js8call
parentapp-arch/cabextract: bump to v1.9 (diff)
downloadgentoo-fb97d8a117f429baf36f1a4abd99ab091a008894.tar.gz
gentoo-fb97d8a117f429baf36f1a4abd99ab091a008894.tar.bz2
gentoo-fb97d8a117f429baf36f1a4abd99ab091a008894.zip
media-radio/js8call: bump
Signed-off-by: Richard Freeman <rich0@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-radio/js8call')
-rw-r--r--media-radio/js8call/Manifest1
-rw-r--r--media-radio/js8call/files/0.8.3-makefile-removesymlink.patch15
-rw-r--r--media-radio/js8call/js8call-0.8.3.ebuild41
3 files changed, 57 insertions, 0 deletions
diff --git a/media-radio/js8call/Manifest b/media-radio/js8call/Manifest
index ed7914414a56..e4beaecfa966 100644
--- a/media-radio/js8call/Manifest
+++ b/media-radio/js8call/Manifest
@@ -1,2 +1,3 @@
DIST js8call-0.8.0.tar.bz2 41226056 BLAKE2B 68894f44c36bc1ede57e9596545a9dd1c3ae53ce0a24e3ea7086f5696ce4deeda2ef8e716ac2e02bfd71c69266a7e867898bfddc2616284a564c753af61e27a6 SHA512 5beb98c7f1d805e3c4dd06a584a5b5d0efc8336da527b6d3d4f53b480c366b8c9e4f902c8c6139bbb379d875538382d1c5a4549dd2a97f408656c7da6fec5796
DIST js8call-0.8.2.tar.bz2 41229377 BLAKE2B 44be0d4e8d8104ee10e57b2cbff6b3bf794034a8cda398c62eff21e50060dbcc0cc0e35d5fafdf0d00dffa65fdaee286a4a566bc5a05bdb3fc7a797c41a6128f SHA512 54e47abbb5a092f85060ecfd51fb2e6aad5cd41dc91ef6224c3ea5bf3c17a3e2e07435a7d7ea73a0838ec644c11eb48ce644b4c7afd6a8e5d6862e1141cc51fe
+DIST js8call-0.8.3.tar.bz2 41231140 BLAKE2B 961a6318ebd9bd7514e662e0e523d04bed8898fbfa4c4d86491690805f15acf78d752839399ddf209b48b6653c6f621aed827ff164a71493ba66398697143be0 SHA512 e90e059bdf5e700cfd710430040c1bc3247bbaeaa258914a5ecaa1ec73d94933ee00f59200b25e0421102045f678204ec54d80e82a6a77abbed7b978d202b8ec
diff --git a/media-radio/js8call/files/0.8.3-makefile-removesymlink.patch b/media-radio/js8call/files/0.8.3-makefile-removesymlink.patch
new file mode 100644
index 000000000000..0bb3349cbdfd
--- /dev/null
+++ b/media-radio/js8call/files/0.8.3-makefile-removesymlink.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2018-10-31 17:52:18.252760284 -0400
++++ a/CMakeLists.txt 2018-10-31 17:52:54.507461091 -0400
+@@ -1272,12 +1272,6 @@
+ #COMPONENT runtime
+ )
+
+- execute_process(COMMAND ln -s /opt/js8call/bin/js8call ljs8call)
+-
+- install(FILES
+- ${CMAKE_BINARY_DIR}/ljs8call DESTINATION /usr/bin/ RENAME js8call
+- #COMPONENT runtime
+- )
+ endif (NOT WIN32 AND NOT APPLE)
+
+
diff --git a/media-radio/js8call/js8call-0.8.3.ebuild b/media-radio/js8call/js8call-0.8.3.ebuild
new file mode 100644
index 000000000000..80fd60203371
--- /dev/null
+++ b/media-radio/js8call/js8call-0.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils vcs-snapshot
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Weak signal ham radio communication"
+HOMEPAGE="https://groups.io/g/js8call"
+SRC_URI="https://bitbucket.org/widefido/wsjtx/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+PATCHES="${FILESDIR}/${PV}-makefile-removesymlink.patch"
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtserialport:5
+ dev-qt/qtprintsupport:5
+ virtual/libusb:1
+ media-libs/portaudio
+ sci-libs/fftw:3.0[threads,fortran]
+ virtual/fortran
+ app-text/asciidoc
+ media-libs/hamlib
+ doc? ( dev-ruby/asciidoctor )"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/bin/rigctl{,d}-local || die
+ rm "${D}"/usr/share/doc/JS8Call -R || die
+}