summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2020-05-01 16:19:55 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2020-05-01 16:19:55 +0200
commit510ea7992948631366eec8d7448081ab2bc6ba7d (patch)
tree5f217283a69b2d2157f6fba540f7de61544d6117 /media-radio/tlf/tlf-1.4.1.ebuild
parentwww-servers/nginx-unit: remove unused patches (diff)
downloadgentoo-510ea7992948631366eec8d7448081ab2bc6ba7d.tar.gz
gentoo-510ea7992948631366eec8d7448081ab2bc6ba7d.tar.bz2
gentoo-510ea7992948631366eec8d7448081ab2bc6ba7d.zip
media-radio/tlf: Version bump
Fixes also -fno-common problem with GCC10 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio/tlf/tlf-1.4.1.ebuild')
-rw-r--r--media-radio/tlf/tlf-1.4.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-radio/tlf/tlf-1.4.1.ebuild b/media-radio/tlf/tlf-1.4.1.ebuild
new file mode 100644
index 000000000000..f247636cf630
--- /dev/null
+++ b/media-radio/tlf/tlf-1.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ dev-libs/glib:2
+ media-libs/hamlib
+ media-sound/sox
+ dev-libs/xmlrpc-c[curl]"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf --enable-fldigi-xmlrpc
+}