summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-06-23 13:00:08 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2021-06-23 13:00:08 +0200
commit96ca8b59c49d972644cb010e33b4668acaf888dd (patch)
tree10559cda10c6f6bad9fad4128197f37ae893f7a0 /media-radio/tlf
parentgames-strategy/hedgewars: Add patch for fpc 3.2 ICE (diff)
downloadgentoo-96ca8b59c49d972644cb010e33b4668acaf888dd.tar.gz
gentoo-96ca8b59c49d972644cb010e33b4668acaf888dd.tar.bz2
gentoo-96ca8b59c49d972644cb010e33b4668acaf888dd.zip
media-radio/tlf: Add subslot dependency
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio/tlf')
-rw-r--r--media-radio/tlf/tlf-1.4.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-radio/tlf/tlf-1.4.1-r1.ebuild b/media-radio/tlf/tlf-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..7c2ff3248f6b
--- /dev/null
+++ b/media-radio/tlf/tlf-1.4.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ dev-libs/glib:2
+ media-libs/hamlib:=
+ media-sound/sox
+ dev-libs/xmlrpc-c[curl]"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+PATCHES=( "${FILESDIR}"/${P}-zone_nr.patch )
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf --enable-fldigi-xmlrpc
+}