summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-03-05 11:36:17 -0500
committerRichard Freeman <rich0@gentoo.org>2020-03-05 11:36:40 -0500
commitd1f2cbc5e0942388f9f269622d48d1ac122bdbcb (patch)
treebb5e763292301e0611c98c3c1ce53caaff977eaf /media-radio/tqsl/tqsl-2.5.1.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {4.19.108,5.4.24,5.5.8}... (diff)
downloadgentoo-d1f2cbc5e0942388f9f269622d48d1ac122bdbcb.tar.gz
gentoo-d1f2cbc5e0942388f9f269622d48d1ac122bdbcb.tar.bz2
gentoo-d1f2cbc5e0942388f9f269622d48d1ac122bdbcb.zip
media-radio/tqsl: bump, EAPI bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'media-radio/tqsl/tqsl-2.5.1.ebuild')
-rw-r--r--media-radio/tqsl/tqsl-2.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-radio/tqsl/tqsl-2.5.1.ebuild b/media-radio/tqsl/tqsl-2.5.1.ebuild
new file mode 100644
index 000000000000..a6cbd247c04e
--- /dev/null
+++ b/media-radio/tqsl/tqsl-2.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils wxwidgets vcs-snapshot
+
+DESCRIPTION="ARRL Logbook of the World"
+HOMEPAGE="http://www.arrl.org/tqsl-download"
+SRC_URI="https://github.com/rich0/trustedqsl-tqsl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LOTW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/expat:=
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ sys-libs/db:=
+ sys-libs/zlib:=
+ x11-libs/wxGTK:3.0="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.txt INSTALL README )
+HTML_DOCS=( html )
+
+WX_GTK_VER=3.0
+
+pkg_setup() {
+ setup-wxwidgets
+}