summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2020-09-08 16:59:27 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2020-09-08 17:00:16 +0200
commit528ae0d10f4c2400dc82620c1c7ea866215b4325 (patch)
tree9f95c4d867021ce4dcf938e0b85ced500b1bdbb3 /media-radio/wsjtx
parentmedia-radio/wsjtx: Drop old (diff)
downloadgentoo-528ae0d10f4c2400dc82620c1c7ea866215b4325.tar.gz
gentoo-528ae0d10f4c2400dc82620c1c7ea866215b4325.tar.bz2
gentoo-528ae0d10f4c2400dc82620c1c7ea866215b4325.zip
media-radio/wsjtx: Fix compiler flags for OpenMP
Due to the mixed compiler suite - clang/clang++ for c/c++ and gfortran for fortran files - the ebuild needs different flag settings for OpenMP. Unfortunately the build system has no clear distinction between the different set of compiler flags. That gets fixed here. Closes: https://bugs.gentoo.org/740292 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio/wsjtx')
-rw-r--r--media-radio/wsjtx/files/wsjtx-clang.patch20
-rw-r--r--media-radio/wsjtx/wsjtx-2.2.2.ebuild3
2 files changed, 22 insertions, 1 deletions
diff --git a/media-radio/wsjtx/files/wsjtx-clang.patch b/media-radio/wsjtx/files/wsjtx-clang.patch
new file mode 100644
index 000000000000..bb6c97a538f6
--- /dev/null
+++ b/media-radio/wsjtx/files/wsjtx-clang.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt 2020-09-08 10:36:55.770304108 +0200
++++ b/CMakeLists.txt 2020-09-08 10:37:28.346406308 +0200
+@@ -1193,7 +1193,7 @@
+ if (OpenMP_C_FLAGS)
+ set_target_properties (wsjt_fort_omp
+ PROPERTIES
+- COMPILE_FLAGS "${OpenMP_C_FLAGS}"
++ COMPILE_FLAGS "${OpenMP_Fortran_FLAGS}"
+ )
+ endif ()
+ set_target_properties (wsjt_fort_omp
+@@ -1260,7 +1260,7 @@
+ if (OpenMP_C_FLAGS)
+ set_target_properties (jt9
+ PROPERTIES
+- COMPILE_FLAGS "${OpenMP_C_FLAGS}"
++ COMPILE_FLAGS "${OpenMP_Fortran_FLAGS}"
+ LINK_FLAGS "${OpenMP_C_FLAGS}"
+ )
+ endif ()
diff --git a/media-radio/wsjtx/wsjtx-2.2.2.ebuild b/media-radio/wsjtx/wsjtx-2.2.2.ebuild
index 01c2452f0a84..923305c594b1 100644
--- a/media-radio/wsjtx/wsjtx-2.2.2.ebuild
+++ b/media-radio/wsjtx/wsjtx-2.2.2.ebuild
@@ -41,7 +41,8 @@ PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch"
"${FILESDIR}/${PN}-fix-unicode.patch"
"${FILESDIR}/${PN}-drop-docs.patch"
"${FILESDIR}/${PN}-2.1.2-qt_helpers.patch"
- "${FILESDIR}/${PN}-2.2.0-werror.patch" )
+ "${FILESDIR}/${PN}-2.2.0-werror.patch"
+ "${FILESDIR}/${PN}-clang.patch" )
DOCS=( AUTHORS BUGS NEWS README THANKS )