summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/wspr/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/wspr/files')
-rw-r--r--media-radio/wspr/files/wspr-2.00-PIL.patch13
-rw-r--r--media-radio/wspr/files/wspr-2.00-libdir.patch53
-rw-r--r--media-radio/wspr/files/wspr-2.00-script.patch25
-rw-r--r--media-radio/wspr/files/wspr-2.00-verbose.patch12
-rw-r--r--media-radio/wspr/files/wspr-3.01-PIL.patch11
-rw-r--r--media-radio/wspr/files/wspr-3.01-numpy.patch23
-rw-r--r--media-radio/wspr/files/wspr-3.01-script.patch19
-rw-r--r--media-radio/wspr/files/wspr-3.01-verbose.patch12
8 files changed, 168 insertions, 0 deletions
diff --git a/media-radio/wspr/files/wspr-2.00-PIL.patch b/media-radio/wspr/files/wspr-2.00-PIL.patch
new file mode 100644
index 000000000000..69bb853396ac
--- /dev/null
+++ b/media-radio/wspr/files/wspr-2.00-PIL.patch
@@ -0,0 +1,13 @@
+--- wspr.py.orig 2013-06-02 18:25:02.000000000 +0200
++++ wspr.py 2013-06-02 18:25:51.000000000 +0200
+@@ -15,7 +15,9 @@
+ from Numeric import zeros
+ import array
+ import dircache
+-import Image, ImageTk, ImageDraw
++from PIL import Image
++from PIL import ImageTk
++from PIL import ImageDraw
+ from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import *
diff --git a/media-radio/wspr/files/wspr-2.00-libdir.patch b/media-radio/wspr/files/wspr-2.00-libdir.patch
new file mode 100644
index 000000000000..e33d7b90871f
--- /dev/null
+++ b/media-radio/wspr/files/wspr-2.00-libdir.patch
@@ -0,0 +1,53 @@
+# Upstream confused LIBDIRS with LDFLAGS in Makefile. f2py wants only
+# LIBDIRS as parameter and takes LDFLAGS only from environment.
+--- Makefile.in.orig 2013-01-31 13:17:23.000000000 +0000
++++ Makefile.in 2013-01-31 13:19:19.000000000 +0000
+@@ -3,7 +3,7 @@
+ INSTALL= install
+ CC ?= @CC@
+ FFLAGS = @FFLAGS@
+-LDFLAGS = @LDFLAGS@
++LIBDIRS = @LIBDIRS@
+ LIBS = @LIBS@ -lfftw3f
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@
+@@ -39,7 +39,7 @@
+ FCV=@FCV@
+ FC_LIB_PATH += @FC_LIB_PATH@
+
+-LDFLAGS += -L${FC_LIB_PATH}
++LIBDIRS += -L${FC_LIB_PATH}
+
+ PYTHON ?= @PYTHON@
+ RM ?= @RM@
+@@ -78,7 +78,7 @@
+ --f77flags="${FFLAGS}" --f90flags="${FFLAGS}" \
+ --fcompiler=${FCV} --f77exec=${FC} --f90exec=${FC} \
+ --opt="-fbounds-check ${FFLAGS}" \
+- ${CPPFLAGS} ${LDFLAGS} ${LIBS} \
++ ${CPPFLAGS} ${LIBDIRS} ${LIBS} \
+ only: $(F2PYONLY) : \
+ $(SRCS2F90) $(SRCS2F77) $(SRCS2C)
+ ${MKDIR} -p build/lib/WsprMod
+# drop hardcoded libdir path,
+# switch LDFLAGS naming to LIBDIRS (see above comment).
+--- configure.ac.orig 2013-01-31 13:19:01.000000000 +0000
++++ configure.ac 2013-01-31 13:19:19.000000000 +0000
+@@ -22,7 +22,7 @@
+
+ dnl Lets guess at some likely places for extra libs/includes XXX -db
+ CPPFLAGS="-I/usr/local/include ${CPPFLAGS}"
+-LDFLAGS="-L/usr/local/lib ${LDFLAGS}"
++LIBDIRS="-L/usr/local/lib ${LIBDIRS}"
+ LIBS=" -lpthread ${LIBS}"
+ FFLAGS_GFORTRAN="${FFLAGS} -fno-range-check -ffixed-line-length-none\
+ -Wall -fbounds-check -fno-second-underscore -fPIC"
+@@ -160,7 +160,7 @@
+ dnl
+ AC_SUBST(PREFIX, "${prefix}")
+ AC_SUBST(CPPFLAGS, "${CPPFLAGS}")
+-AC_SUBST(LDFLAGS, "${LDFLAGS}")
++AC_SUBST(LIBDIRS, "${LIBDIRS}")
+ AC_SUBST(LIBS, "${LIBS}")
+ AC_SUBST(CFLAGS)
+ AC_SUBST(FFLAGS)
diff --git a/media-radio/wspr/files/wspr-2.00-script.patch b/media-radio/wspr/files/wspr-2.00-script.patch
new file mode 100644
index 000000000000..e75c11782786
--- /dev/null
+++ b/media-radio/wspr/files/wspr-2.00-script.patch
@@ -0,0 +1,25 @@
+# make python code into a script
+# and fix shell script
+--- wspr.py.orig 2013-02-01 13:24:30.000000000 +0000
++++ wspr.py 2013-02-01 13:23:30.000000000 +0000
+@@ -1,3 +1,4 @@
++#!/usr/bin/python
+ #------------------------------------------------------------------- WSPR
+ # $Date: 2013/02/07 14:35:21 $ $Revision: 1.1 $
+ #
+--- wspr.orig 2013-02-02 08:10:17.000000000 +0000
++++ wspr 2013-02-02 08:10:56.000000000 +0000
+@@ -1,12 +1,7 @@
+ #!/bin/sh
+-if [ -e /usr/local/bin/python ] ; then
+- LOCALBASE=/usr/local/
+-else
+- LOCALBASE=/usr/
+-fi
+ if [ ! -e ~/.wspr ] ; then
+ mkdir ~/.wspr
+ mkdir ~/.wspr/save
+ fi
+ cd ~/.wspr
+-python ${LOCALBASE}/bin/wspr.py
++/usr/bin/wspr.py
diff --git a/media-radio/wspr/files/wspr-2.00-verbose.patch b/media-radio/wspr/files/wspr-2.00-verbose.patch
new file mode 100644
index 000000000000..9036e0d868a4
--- /dev/null
+++ b/media-radio/wspr/files/wspr-2.00-verbose.patch
@@ -0,0 +1,12 @@
+# make f2py verbose
+--- Makefile.in.orig 2013-02-07 12:22:41.000000000 +0000
++++ Makefile.in 2013-02-07 12:23:11.000000000 +0000
+@@ -74,7 +74,7 @@
+ OBJS2C = ${SRCS2C:.c=.o}
+
+ WsprMod/w.so: ${OBJS2C} $(SRCS2F90) $(SRCS2F77) acom1.f90
+- ${F2PY} -c --quiet --noopt --debug -m w \
++ ${F2PY} -c --noopt --debug -m w \
+ --f77flags="${FFLAGS}" --f90flags="${FFLAGS}" \
+ --fcompiler=${FCV} --f77exec=${FC} --f90exec=${FC} \
+ --opt="-fbounds-check ${FFLAGS}" \
diff --git a/media-radio/wspr/files/wspr-3.01-PIL.patch b/media-radio/wspr/files/wspr-3.01-PIL.patch
new file mode 100644
index 000000000000..ce4689195147
--- /dev/null
+++ b/media-radio/wspr/files/wspr-3.01-PIL.patch
@@ -0,0 +1,11 @@
+--- wspr.py.orig 2014-06-23 21:25:51.000000000 +0200
++++ wspr.py 2014-06-23 21:26:03.000000000 +0200
+@@ -35,7 +35,7 @@
+ from Numeric import zeros
+ import array
+ import dircache
+-import Image, ImageTk, ImageDraw
++from PIL import Image, ImageTk, ImageDraw
+ from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import *
diff --git a/media-radio/wspr/files/wspr-3.01-numpy.patch b/media-radio/wspr/files/wspr-3.01-numpy.patch
new file mode 100644
index 000000000000..2c9174dff58a
--- /dev/null
+++ b/media-radio/wspr/files/wspr-3.01-numpy.patch
@@ -0,0 +1,23 @@
+# Numpy-1.9 dropped oldnumeric and numarray
+--- WsprMod/specjt.py.orig 2015-05-18 15:49:37.000000000 +0200
++++ WsprMod/specjt.py 2015-05-18 15:49:48.000000000 +0200
+@@ -12,7 +12,7 @@
+ import w
+
+ try:
+- from numpy.oldnumeric import zeros, multiarray
++ from numpy import zeros, multiarray
+ except:
+ from Numeric import zeros, multiarray
+ import Image, ImageTk, ImageDraw
+--- wspr.py.orig 2015-05-18 15:47:13.000000000 +0200
++++ wspr.py 2015-05-18 15:47:38.000000000 +0200
+@@ -31,7 +31,7 @@
+ from WsprMod import palettes
+ from math import log10
+ try:
+- from numpy.oldnumeric import zeros
++ from numpy import zeros
+ except:
+ from Numeric import zeros
+ import array
diff --git a/media-radio/wspr/files/wspr-3.01-script.patch b/media-radio/wspr/files/wspr-3.01-script.patch
new file mode 100644
index 000000000000..f64a11b68a64
--- /dev/null
+++ b/media-radio/wspr/files/wspr-3.01-script.patch
@@ -0,0 +1,19 @@
+--- wspr.py.orig 2014-06-24 19:13:55.000000000 +0200
++++ wspr.py 2014-06-24 19:14:43.000000000 +0200
+@@ -1,3 +1,4 @@
++#!/usr/bin/python
+ #-------------------------------------------------------------------- WSPR
+ # $Date: 2014/06/26 09:15:53 $ $Revision: 1.1 $
+ #
+--- wspr.orig 2014-06-24 18:57:00.000000000 +0200
++++ wspr 2014-06-24 19:09:50.000000000 +0200
+@@ -1,2 +1,7 @@
+-LD_LIBRARY_PATH=./lib
+-python -O wspr.py
++#!/bin/sh
++if [ ! -e ~/.wspr ] ; then
++ mkdir ~/.wspr
++ mkdir ~/.wspr/save
++fi
++cd ~/.wspr
++/usr/bin/wspr.py
diff --git a/media-radio/wspr/files/wspr-3.01-verbose.patch b/media-radio/wspr/files/wspr-3.01-verbose.patch
new file mode 100644
index 000000000000..b697cfe444dd
--- /dev/null
+++ b/media-radio/wspr/files/wspr-3.01-verbose.patch
@@ -0,0 +1,12 @@
+# make f2py verbose
+--- Makefile.in.orig 2014-06-23 21:14:51.000000000 +0200
++++ Makefile.in 2014-06-23 21:15:11.000000000 +0200
+@@ -95,7 +95,7 @@
+ OBJS2C = ${SRCS2C:.c=.o}
+
+ WsprMod/w.so: ${OBJS2C} $(SRCS2C) $(SRCS2F90) $(SRCS2F77) acom1.f90
+- ${F2PY} -c --quiet --noopt --debug -m w \
++ ${F2PY} -c --noopt --debug -m w \
+ --f77flags="${FFLAGS}" --f90flags="${FFLAGS}" \
+ --fcompiler=${FCV} --f77exec=${FC} --f90exec=${FC} \
+ --opt="-fbounds-check ${FFLAGS}" \