summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-07-15 17:43:21 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2022-07-15 17:50:18 +0200
commit51197e7f5c51eb29624651741baaa474a03a101d (patch)
tree4c1e17b8d3aee2d983e1ff1bc220c898ec199727 /media-radio
parentnet-wireless/gnuradio: Major version bump to 3.10.3.0 (diff)
downloadgentoo-51197e7f5c51eb29624651741baaa474a03a101d.tar.gz
gentoo-51197e7f5c51eb29624651741baaa474a03a101d.tar.bz2
gentoo-51197e7f5c51eb29624651741baaa474a03a101d.zip
media-radio/unixcw: add 3.6.0
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/unixcw/Manifest1
-rw-r--r--media-radio/unixcw/files/unixcw-3.6-tinfo.patch30
-rw-r--r--media-radio/unixcw/unixcw-3.6.0.ebuild74
3 files changed, 105 insertions, 0 deletions
diff --git a/media-radio/unixcw/Manifest b/media-radio/unixcw/Manifest
index 1bc0ae730a26..a2d5606bf515 100644
--- a/media-radio/unixcw/Manifest
+++ b/media-radio/unixcw/Manifest
@@ -1 +1,2 @@
DIST unixcw-3.5.1.tar.gz 740331 BLAKE2B 9b5b4b819cf75ca0b10d773ebdf9869bf835c49f10c54b5bd34441b417d48d9a92abc9390a41870bf1c09fbbfe932554307abba181cad3b8631947adcf9890b1 SHA512 b59499723d810a537a2f5ab2b4b34c83a1c8c815af82a60ba29f4d9cee445525e530136f4e202db6b87305ac7a818fa6e59214a45c6bffce299eb50b58c866e1
+DIST unixcw-3.6.0.tar.gz 870148 BLAKE2B 4eca3fe63ce7aec43e16ecca8120018e1bda6541f707ac9857db1f9dc6181a53ee24c7328f0a1f97a6aa1993600d68d9313e0567c12dfcf7a061837885aaefcb SHA512 17abdfaeb2b4e7459e1efd93f5f85a8ed89fde06e5b8d23d83c9f1c76888bc9048af1a8adc9c030f560e94e0dd0576b3a30bf040fece4d13e001d01734d6338b
diff --git a/media-radio/unixcw/files/unixcw-3.6-tinfo.patch b/media-radio/unixcw/files/unixcw-3.6-tinfo.patch
new file mode 100644
index 000000000000..855eccc045eb
--- /dev/null
+++ b/media-radio/unixcw/files/unixcw-3.6-tinfo.patch
@@ -0,0 +1,30 @@
+--- configure.ac.old 2017-03-07 13:31:46.074580930 +0100
++++ configure.ac 2017-03-07 13:33:25.640924331 +0100
+@@ -347,7 +347,7 @@
+ AC_DEFINE([LIBCW_WITH_PULSEAUDIO], [1], [Define as 1 if your build machine can support PulseAudio.])
+ fi
+
+-
++PKG_PROG_PKG_CONFIG
+
+ if test "$enable_cwcp" = "no" ; then
+ WITH_CWCP='no'
+@@ -355,6 +355,7 @@
+ AC_CHECK_LIB(curses, initscr)
+ if test $ac_cv_lib_curses_initscr = 'yes' ; then
+ WITH_CWCP='yes'
++ PKG_CHECK_MODULES(ncurses, ncurses, [NCURSES_LIB="$ncurses_LIBS"], )
+ else
+ WITH_CWCP='no'
+ AC_MSG_WARN([Cannot find libcurses - unable to build cwcp])
+--- src/cwcp/Makefile.am.old 2022-07-15 17:36:58.554778217 +0200
++++ src/cwcp/Makefile.am 2022-07-15 17:37:49.169570822 +0200
+@@ -28,7 +28,7 @@
+ # Target-specific linker flags (objects to link). Order is important:
+ # first static library then dynamic. Otherwise linker may not find
+ # symbols from the dynamic library.
+-cwcp_LDADD = $(top_builddir)/src/cwutils/lib_cwcp.a -lcurses $(INTL_LIB) -L$(top_builddir)/src/libcw/.libs -lcw
++cwcp_LDADD = $(top_builddir)/src/cwutils/lib_cwcp.a ${ncurses_LIBS} $(INTL_LIB) -L$(top_builddir)/src/libcw/.libs -lcw
+
+
+ # copy man page to proper directory during installation
diff --git a/media-radio/unixcw/unixcw-3.6.0.ebuild b/media-radio/unixcw/unixcw-3.6.0.ebuild
new file mode 100644
index 000000000000..fa0f69b925ac
--- /dev/null
+++ b/media-radio/unixcw/unixcw-3.6.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A package of programs that fit together to form a morse code tutor program"
+HOMEPAGE="http://unixcw.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="alsa ncurses pulseaudio suid test qt5"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ncurses? ( sys-libs/ncurses:= )
+ qt5? ( dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5 )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool"
+
+src_prepare() {
+ append-cflags -std=gnu11
+ append-cxxflags -std=gnu++11
+ eapply -p0 "${FILESDIR}"/$PN-3.6-tinfo.patch
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) \
+ $(use_enable pulseaudio ) \
+ $(use_enable alsa ) \
+ $(use_enable ncurses cwcp ) \
+ $(use_enable qt5 xcwcp ) \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -type f -delete || die
+ dodoc ChangeLog NEWS README
+ if ! use suid ; then
+ fperms 711 /usr/bin/cw
+ if use ncurses ; then
+ fperms 711 /usr/bin/cwcp
+ fi
+ if use qt5 ; then
+ fperms 711 /usr/bin/xcwcp
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use suid ; then
+ ewarn "You have choosen to install 'cw', 'cwcp' and 'xcwcp' setuid"
+ ewarn "by setting USE=suid."
+ ewarn "Be aware that this is a security risk and not recommended."
+ ewarn ""
+ ewarn "These files do only need root access if you want to use the"
+ ewarn "PC speaker for morse sidetone output. You can alternativly"
+ ewarn "drop USE=suid and use sudo."
+ else
+ elog "Be aware that 'cw', 'cwcp' and 'xcwcp' needs root access if"
+ elog "you want to use the PC speaker for morse sidetone output."
+ elog "You can call the programs via sudo for that (see 'man sudo')."
+ fi
+}