summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-03-27 21:39:07 -0400
committerRick Farina <zerochaos@gentoo.org>2019-03-27 21:39:07 -0400
commit6f583461ad516c5cc2a8142514c20f247db11614 (patch)
treeb9ce4c9a313251a05dd346dfd947a676a3ecdfa0 /media-radio
parentmail-filter/procmail: re-add security fix with crash fix (diff)
downloadgentoo-6f583461ad516c5cc2a8142514c20f247db11614.tar.gz
gentoo-6f583461ad516c5cc2a8142514c20f247db11614.tar.bz2
gentoo-6f583461ad516c5cc2a8142514c20f247db11614.zip
media-radio/fsync-mdc1200-decode: add tagged release
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/fsync-mdc1200-decode/Manifest1
-rw-r--r--media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild34
-rw-r--r--media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild4
3 files changed, 37 insertions, 2 deletions
diff --git a/media-radio/fsync-mdc1200-decode/Manifest b/media-radio/fsync-mdc1200-decode/Manifest
new file mode 100644
index 000000000000..3c867ee5380e
--- /dev/null
+++ b/media-radio/fsync-mdc1200-decode/Manifest
@@ -0,0 +1 @@
+DIST fsync-mdc1200-decode-1.0.tar.gz 19791 BLAKE2B 86000b3b6a71895c211ae123eedfd54ba0dfa9bfc8619a28effb1f5187349aa33968acf6a24fd4e7b10e07a5693cf3410d5242d9719f34bec0a847794098196a SHA512 94525b88800f285816d6c76f0474854543a805f85a3156cd516a3c952ce05e40c9c845dfb799eb5aea9cd2e659713c468e35407804b42db98981dff91d08fb92
diff --git a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
new file mode 100644
index 000000000000..eaf4b75afef9
--- /dev/null
+++ b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux Fleetsync / MCD1200 decoder"
+HOMEPAGE="https://github.com/russinnes/fsync-mdc1200-decode"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+if [ "${PV}" = 9999 ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/russinnes/fsync-mdc1200-decode.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/russinnes/fsync-mdc1200-decode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+IUSE=""
+
+DEPEND="media-sound/pulseaudio:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ $(tc-getCC) -o fsync-mdc1200-decode ${CFLAGS} ${LDFLAGS} demod.c fsync_decode.c mdc_decode.c $(pkg-config --cflags --libs libpulse-simple)
+}
+
+src_install() {
+ dobin fsync-mdc1200-decode
+}
diff --git a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
index 00ae9f5dee31..eaf4b75afef9 100644
--- a/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
+++ b/media-radio/fsync-mdc1200-decode/fsync-mdc1200-decode-9999.ebuild
@@ -15,8 +15,8 @@ if [ "${PV}" = 9999 ]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/russinnes/fsync-mdc1200-decode.git"
else
- KEYWORDS=""
- SRC_URI=""
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/russinnes/fsync-mdc1200-decode/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
IUSE=""