summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-12-03 23:33:47 +0000
committerMarek Szuba <marecki@gentoo.org>2021-12-03 23:39:32 +0000
commita7b4a66e768c31054e4fbe73ea1ce35b2742419c (patch)
tree2047c01b304cf481a94081676a7f2653cda24de5 /media-radio
parentnet-im/signal-desktop-bin: remove clone3 USEdep for 5.25.0 (diff)
downloadgentoo-a7b4a66e768c31054e4fbe73ea1ce35b2742419c.tar.gz
gentoo-a7b4a66e768c31054e4fbe73ea1ce35b2742419c.tar.bz2
gentoo-a7b4a66e768c31054e4fbe73ea1ce35b2742419c.zip
media-radio/tqsl: add 2.5.9
Invoking long-overdue maintainer time-out on this one. For obvious reasons in light of the above, SRC_URI had to be updated and now points to the official upstream source tarball. Closes: https://bugs.gentoo.org/701704 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tqsl/Manifest1
-rw-r--r--media-radio/tqsl/files/tqsl-2.5.9-lib_suffix.patch14
-rw-r--r--media-radio/tqsl/tqsl-2.5.9.ebuild36
3 files changed, 51 insertions, 0 deletions
diff --git a/media-radio/tqsl/Manifest b/media-radio/tqsl/Manifest
index 3762b4a5ee19..fbe76502f7db 100644
--- a/media-radio/tqsl/Manifest
+++ b/media-radio/tqsl/Manifest
@@ -1 +1,2 @@
DIST tqsl-2.5.1.tar.gz 4462202 BLAKE2B f62afe6003b782e5e092fbd99a90a79cc4b020004092f958dad6f7c695d125e31b28b47e7945ccee1fd88c87b290f93145592cac1bd9c52501c34de901f78d74 SHA512 7578572f64c269a41f3fa62ebe526baee4ac382fac81549e79d676da5dc4f3dd3d2a4ce31bc741b43a07eaf164a33beeb1987dd61df1a92ede7b762a8df532f3
+DIST tqsl-2.5.9.tar.gz 3677621 BLAKE2B dc367eb9206665d5cf3126715c04e9a718b5cf54915082c0de088767f646f0d2b40d16fda7ae77e5cddf66034f49f3400a30b00e300454fbe794532b8bf674ea SHA512 feb6bc94d801c5e698df0ea206d9cd5df79c2cba066bc0420ac96f75254e7989eb5d03237e50f31b2d58b921818a3bfc1d8e1a449d5fa5c4869525bf16173118
diff --git a/media-radio/tqsl/files/tqsl-2.5.9-lib_suffix.patch b/media-radio/tqsl/files/tqsl-2.5.9-lib_suffix.patch
new file mode 100644
index 000000000000..2a35736ae83d
--- /dev/null
+++ b/media-radio/tqsl/files/tqsl-2.5.9-lib_suffix.patch
@@ -0,0 +1,14 @@
+This definition causes the following tests to effectively turn no-op,
+resulting in strict-multilib violations on amd64.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -18,8 +18,6 @@
+ SET(LINUX TRUE)
+ ENDIF ()
+
+-SET (LIB_SUFFIX "")
+-
+ # Pre-set LIB_SUFFIX for 64-bit Linux platforms
+ IF (LINUX AND CMAKE_SHARED_LIBRARY_PREFIX STREQUAL "lib64")
+ SET (LIB_SUFFIX "64")
diff --git a/media-radio/tqsl/tqsl-2.5.9.ebuild b/media-radio/tqsl/tqsl-2.5.9.ebuild
new file mode 100644
index 000000000000..22cc02985616
--- /dev/null
+++ b/media-radio/tqsl/tqsl-2.5.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake wxwidgets
+
+DESCRIPTION="ARRL Logbook of the World"
+HOMEPAGE="https://www.arrl.org/tqsl-download"
+SRC_URI="https://www.arrl.org/${PN}/${P}.tar.gz"
+
+LICENSE="LOTW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/expat:=
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ sys-libs/db:=
+ sys-libs/zlib:=
+ x11-libs/wxGTK:${WX_GTK_VER}="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.9-lib_suffix.patch
+)
+
+DOCS=( AUTHORS.txt INSTALL README )
+HTML_DOCS=( html/. )
+
+src_configure() {
+ setup-wxwidgets
+ cmake_src_configure
+}