summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-12-24 12:10:51 +0100
committerMarek Szuba <marecki@gentoo.org>2023-12-24 12:21:42 +0100
commitdbcf8b4f2c359007f52aaaa2c4500713dba420f9 (patch)
tree66b71c4a5becbbba1ea3831f9c90796c07167a81 /media-radio
parentdev-ruby/haml: Stabilize 6.2.3 arm64, #920655 (diff)
downloadgentoo-dbcf8b4f2c359007f52aaaa2c4500713dba420f9.tar.gz
gentoo-dbcf8b4f2c359007f52aaaa2c4500713dba420f9.tar.bz2
gentoo-dbcf8b4f2c359007f52aaaa2c4500713dba420f9.zip
media-radio/chirp: add 20231223
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/chirp/Manifest1
-rw-r--r--media-radio/chirp/chirp-20231223.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-radio/chirp/Manifest b/media-radio/chirp/Manifest
index 9ab0a6d4d499..40406878c65e 100644
--- a/media-radio/chirp/Manifest
+++ b/media-radio/chirp/Manifest
@@ -1,3 +1,4 @@
DIST chirp-20230917.tar.gz 1754068 BLAKE2B 462f047310ac8ca15098365062109716ccd0a695ab86910f6c6bd6ef11b094b5cdb59949238e49e6baf3a08cc12e41766a9306d9fe685e35a2040eb9d7602ad5 SHA512 50ce4036d5ebeebbc2c4badb8c4f23ce13fcb66a3b016564655c25b30a032cbb8c0b62857ffbe5dac28967d2d70bb721ac45209eb6405a9c87263b225bd8d049
DIST chirp-20231021.tar.gz 1776607 BLAKE2B 8958bcf5d8ba310c07772b9a2c214d5d2785d2e39cc60039c405728cedf0001f71ea2110cae7e67dca72c9ebe7a61834c9c308f56f49d24c8f7f962dfc5aa067 SHA512 131b8ab81a2b1618438e1c03129c19be57642fa05a01ddd3d4d2f5a09e2eb5a8184bea15b306af768d8c584935f81a145f91cc058ab57238981efd0ed2e73f09
DIST chirp-20231125.tar.gz 1824835 BLAKE2B 327d34867324ddf326709c6e098ccd80810015023807e238a1f63650328236cf791c14a6cbfdbb4bcfea7875dad394846fe5eec3c2a167623fcfebf8980d4954 SHA512 cef4a7c26ae0784c5031db96d2b632e39ab7eb7d61ab1f486b4a4bc9842d16536de22651f2cabb21394e0382af0f5488cb65ac0e609d0936f8db3747f4a5aa7a
+DIST chirp-20231223.tar.gz 1850008 BLAKE2B b0d1d68889975d03c5b6a454d64e6fe9ac9f254423aaa77eff81d74cf3760cab8df0e9a411bab85c2ffaffde75ca515b72d7efdd5b9bdc0fc7b68eb5ef233e16 SHA512 5d8bf781d994e33c7de678b2ed31469f43dce9bebc99ee0d57b88ddf6eb41e23d8ec3e3bf5ef5ad4258f31dc47cb2748eeb290bceec38f0c859a9783259ff8d0
diff --git a/media-radio/chirp/chirp-20231223.ebuild b/media-radio/chirp/chirp-20231223.ebuild
new file mode 100644
index 000000000000..5b1a95d408b4
--- /dev/null
+++ b/media-radio/chirp/chirp-20231223.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by wxpython
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A free, open-source tool for programming your radio"
+HOMEPAGE="https://chirp.danplanet.com/"
+SRC_URI="https://trac.chirp.danplanet.com/${PN}_next/next-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gui radioreference"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ gui? (
+ dev-python/wxpython:4.0[${PYTHON_USEDEP}]
+ dev-python/yattag[${PYTHON_USEDEP}]
+ )
+ radioreference? ( dev-python/suds-community[${PYTHON_USEDEP}] )
+')"
+BDEPEND="test? ( $(python_gen_cond_dep '
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+') )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20230818_no-future.patch
+)
+
+distutils_enable_tests pytest
+
+# The alias map is an internal developer file not included in release tarballs.
+# Other disabled tests require Internet access.
+EPYTEST_DESELECT=(
+ tests/unit/test_directory.py::TestAliasMap
+ tests/unit/test_network_sources.py
+ tests/unit/test_repeaterbook.py
+)
+
+python_test() {
+ # From the contents of tests/ upstream currently only runs unit and driver
+ # tests, and the latter can take so long that they have even got a special
+ # script for only running them on drivers whose code has changed
+ # with respect to origin/master.
+ epytest tests/unit/
+}
+
+src_install() {
+ distutils-r1_src_install
+ if ! use gui; then
+ rm "${ED}"/usr/bin/${PN} || die
+ fi
+}