summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-25 19:48:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-08 11:40:19 +0200
commiteedab163cf3f962eadcba106053e1e2d8aa5667c (patch)
treee5d45aa29178ca3027ced61f5855337fe2a02363 /media-radio
parentmedia-radio/svxlink: Move dev-qt/linguist-tools:5 to BDEPEND (diff)
downloadgentoo-eedab163cf3f962eadcba106053e1e2d8aa5667c.tar.gz
gentoo-eedab163cf3f962eadcba106053e1e2d8aa5667c.tar.bz2
gentoo-eedab163cf3f962eadcba106053e1e2d8aa5667c.zip
media-radio/wsjtx: Move dev-qt/linguist-tools:5 to BDEPEND
Fix HOMEPAGE to use https Drop superfluous eapply_user, called by default in cmake_src_prepare Drop superfluous src_compile() Drop one-time use of global var Minor ebuild style fixes (empty line after EAPI, PATCHES indentation) Bug: https://bugs.gentoo.org/544938 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/wsjtx/wsjtx-2.5.4.ebuild32
1 files changed, 13 insertions, 19 deletions
diff --git a/media-radio/wsjtx/wsjtx-2.5.4.ebuild b/media-radio/wsjtx/wsjtx-2.5.4.ebuild
index e6faedc87d75..c1d207649d28 100644
--- a/media-radio/wsjtx/wsjtx-2.5.4.ebuild
+++ b/media-radio/wsjtx/wsjtx-2.5.4.ebuild
@@ -2,13 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake flag-o-matic
-MY_P=${P/_/-}
+inherit cmake flag-o-matic
DESCRIPTION="Weak signal ham radio communication"
-HOMEPAGE="http://physics.princeton.edu/pulsar/K1JT/wsjtx.html"
+HOMEPAGE="https://physics.princeton.edu//pulsar/K1JT/wsjtx.html"
SRC_URI="https://physics.princeton.edu/pulsar/k1jt/${P}.tgz"
+S=${WORKDIR}/wsjtx
LICENSE="GPL-3"
SLOT="0"
@@ -34,29 +34,27 @@ RDEPEND="
virtual/fortran
app-text/asciidoc
doc? ( dev-ruby/asciidoctor )"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools
- "
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools"
-S=${WORKDIR}/wsjtx
-
-PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch"
- "${FILESDIR}/${PN}-2.3.0-drop-docs.patch"
- "${FILESDIR}/${PN}-2.1.2-qt_helpers.patch"
- "${FILESDIR}/${PN}-2.2.0-werror.patch"
- "${FILESDIR}/${PN}-clang.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.1-hamlib.patch"
+ "${FILESDIR}/${PN}-2.3.0-drop-docs.patch"
+ "${FILESDIR}/${PN}-2.1.2-qt_helpers.patch"
+ "${FILESDIR}/${PN}-2.2.0-werror.patch"
+ "${FILESDIR}/${PN}-clang.patch"
+)
DOCS=( AUTHORS BUGS NEWS README THANKS )
src_unpack() {
unpack ${A}
- unpack "${WORKDIR}/${MY_P}/src/wsjtx.tgz"
+ unpack "${WORKDIR}/${P/_/-}/src/wsjtx.tgz"
}
src_prepare() {
sed -i -e "s/COMMAND \${GZIP_EXECUTABLE}/# COMMAND/" \
manpages/CMakeLists.txt || die
- eapply_user
cmake_src_prepare
}
@@ -69,10 +67,6 @@ src_configure() {
cmake_src_configure
}
-src_compile() {
- cmake_src_compile
-}
-
src_install() {
cmake_src_install
rm "${D}"/usr/bin/rigctl{,d}-wsjtx || die