summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-04-07 07:46:11 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-04-07 07:46:11 +0200
commitb7a8300a16e852ae7f826594bc53d7135b5f41c4 (patch)
treed0a171583f0264cd5a41f94e4cc4230e632d5229 /media-sound/abcmidi
parentnet-analyzer/gnome-nettool: Fix dependencies (diff)
downloadgentoo-b7a8300a16e852ae7f826594bc53d7135b5f41c4.tar.gz
gentoo-b7a8300a16e852ae7f826594bc53d7135b5f41c4.tar.bz2
gentoo-b7a8300a16e852ae7f826594bc53d7135b5f41c4.zip
media-sound/abcmidi: bump to 2022.04.06
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/abcmidi')
-rw-r--r--media-sound/abcmidi/Manifest1
-rw-r--r--media-sound/abcmidi/abcmidi-2022.04.06.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/abcmidi/Manifest b/media-sound/abcmidi/Manifest
index 813fcf1c1aa3..b8d4070c3505 100644
--- a/media-sound/abcmidi/Manifest
+++ b/media-sound/abcmidi/Manifest
@@ -1,3 +1,4 @@
DIST abcMIDI-2022.02.21.zip 609368 BLAKE2B 0608d9539d0a66f739a820693c5a9884d1b39b68e4bcd3d21ce020ef240de6e19eacb52bc35ed7a9d4c4fde47e6265c415cf4d80711853904ccdc1ffd752cefe SHA512 515c6ebef75a5b0592578dab6f5d940ed5e25811dd66f15f85ebb1e6fdd7bcbcffdd4d361e0f16a78144323fac14a0cbd1a7ed6b14c7039e2d48986d40765171
DIST abcMIDI-2022.03.08.zip 609510 BLAKE2B 231eb517a2d47993ed39e509d377d14ec2311fe49128bf559799ea1fabd3ba79c69307f2d7b9d44fec2279e42d0575141088463ca96aa0f9dda5bbecc305a92b SHA512 3267bcecad586e0aadc5fbc2801c0c992ba765094fdf5d3b71a8634f4433a950c64b0c863bec496bd21f8a630c0e768cbc39d50d58e6cf9d2769a66bf265a8c7
DIST abcMIDI-2022.03.20.zip 609912 BLAKE2B 8972f6944897d49c1281be9d9b1368278d62fcbfc909651d1fb1347d3efef4ab145f049bac05e11f09118548e9c3c3a753f9367c9e90d933af96e74b71bd6b19 SHA512 138480f0d2a36b573e63a9214d7e2e2109a3e6b55e94999376a333da1978fea0addb5359b0d469d801924d6e039b0eb164a28a9cfad02d73cba1069a29dbfc9b
+DIST abcMIDI-2022.04.06.zip 609956 BLAKE2B c140bcacc94d8e6193ba6220c1747861a11d79e5b394ff5826edfdb3029e57b3a6d9443a557baf6279d4a7c9e6488dcb2c8d0e6a05858046be53fc52be2640bd SHA512 06d4ddfc4f7bbc1906604629e3b2ca7ebf8d2f89edb478d2068b2ba4efab6ff1d96aeebd6344ea2ebc7a92c23cf49d08b40bc97c47458e526d505313fb52a527
diff --git a/media-sound/abcmidi/abcmidi-2022.04.06.ebuild b/media-sound/abcmidi/abcmidi-2022.04.06.ebuild
new file mode 100644
index 000000000000..11f547f4cb8e
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2022.04.06.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="abcMIDI-${PV}"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
+SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+ sed -i "s:-O2::" configure.ac || die
+ sed -i "s:@datarootdir@/doc/abcmidi:@docdir@:" Makefile.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}