summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-10 13:22:11 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-10 13:22:11 +0200
commit4df3cb7fcc16ff76d739b11aef408c3f71f174cc (patch)
tree28aac094a5515b52bd1af2b9e3eef930a7d17665 /media-sound/alsaplayer
parentapp-misc/scrub: restore old 2.6.1 (diff)
downloadgentoo-4df3cb7fcc16ff76d739b11aef408c3f71f174cc.tar.gz
gentoo-4df3cb7fcc16ff76d739b11aef408c3f71f174cc.tar.bz2
gentoo-4df3cb7fcc16ff76d739b11aef408c3f71f174cc.zip
media-sound/alsaplayer: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/alsaplayer')
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild (renamed from media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild)31
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild37
2 files changed, 48 insertions, 20 deletions
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild
index 098fdbbe3336..70ee1adcfa99 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools desktop xdg
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ~ppc ~riscv ~sparc x86"
IUSE="+alsa audiofile doc flac gtk id3tag jack mad mikmod nas nls ogg opengl oss vorbis xosd"
+REQUIRED_USE="|| ( alsa jack nas oss )"
RDEPEND="
media-libs/libsndfile:=
@@ -31,27 +32,17 @@ RDEPEND="
vorbis? ( media-libs/libvorbis )
xosd? ( x11-libs/xosd )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )
oss? ( virtual/os-headers )"
-REQUIRED_USE="|| ( alsa jack nas oss )"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.ebuild )
src_prepare() {
default
-
- sed -i \
- -e 's:AM_CFLAGS = $(AM_CXXFLAGS)::' \
- output/jack/Makefile.am || die
-
- sed -i \
- -e 's:-O2 -funroll-loops -finline-functions -ffast-math::' \
- configure.ac || die
-
- sed -i \
- -e "s:/usr/lib:/usr/$(get_libdir):" \
- configure.ac config.rpath || die
-
+ cp "${BROOT}"/usr/share/gettext/config.rpath . || die
eautoreconf
}
@@ -83,5 +74,5 @@ src_install() {
newicon interface/gtk2/pixmaps/logo.xpm ${PN}.xpm
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild
new file mode 100644
index 000000000000..b51277317e0f
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.ebuild
@@ -0,0 +1,37 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -82,11 +82,6 @@
+ dnl PKGCONFIG preparations
+ dnl ======================
+
+-if test -z $PKG_CONFIG_PATH; then
+- PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
+-fi
+-
+-export PKG_CONFIG_PATH
+
+
+ dnl ===============
+@@ -639,10 +634,10 @@
+
+ AC_MSG_CHECKING(for gcc optimization flags)
+ old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"
++CFLAGS="$CFLAGS -Wall"
+ AC_TRY_COMPILE([#include <stdio.h>],
+ [ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"],[ EXTRA_OPT_CFLAGS=""])
++[ EXTRA_OPT_CFLAGS="$CFLAGS -Wall"],[ EXTRA_OPT_CFLAGS=""])
+ CFLAGS=$old_cflags
+ AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+
+--- a/output/jack/Makefile.am
++++ b/output/jack/Makefile.am
+@@ -24,7 +24,6 @@
+
+ AM_CXXFLAGS = $(COMMON_FLAGS) $(JACK_CFLAGS)
+
+-AM_CFLAGS = $(AM_CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/output
+