summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-31 22:09:10 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-31 22:09:24 +0100
commit8675d6f22ed33a410bcdfe9ba952947775bfd3c7 (patch)
tree7409dafe25c718236cf4585b86d8bfd2db2401ff /media-sound/amsynth/amsynth-1.6.4.ebuild
parentdev-perl/GnuPG-Interface: Remove old (diff)
downloadgentoo-8675d6f22ed33a410bcdfe9ba952947775bfd3c7.tar.gz
gentoo-8675d6f22ed33a410bcdfe9ba952947775bfd3c7.tar.bz2
gentoo-8675d6f22ed33a410bcdfe9ba952947775bfd3c7.zip
media-sound/amsynth: Version bump to 1.6.4
Gentoo-Bug: 572572 * EAPI=6 Package-Manager: portage-2.2.27
Diffstat (limited to 'media-sound/amsynth/amsynth-1.6.4.ebuild')
-rw-r--r--media-sound/amsynth/amsynth-1.6.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/amsynth/amsynth-1.6.4.ebuild b/media-sound/amsynth/amsynth-1.6.4.ebuild
new file mode 100644
index 000000000000..17926d60b63d
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/nixxcode/amsynth/"
+SRC_URI="https://github.com/nixxcode/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1:= )
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}