summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2017-05-09 07:32:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-09 09:28:02 +0200
commitfab7558cfbb06bc272b8241c876135b6565f8575 (patch)
treef58ba418511d46cf39fa975f6a75e1e999254a6e /media-sound/amsynth/amsynth-1.7.1-r1.ebuild
parentmedia-plugins/calf: depend on virtual/jack (diff)
downloadgentoo-fab7558cfbb06bc272b8241c876135b6565f8575.tar.gz
gentoo-fab7558cfbb06bc272b8241c876135b6565f8575.tar.bz2
gentoo-fab7558cfbb06bc272b8241c876135b6565f8575.zip
media-sound/amsynth: depend on virtual/jack
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-sound/amsynth/amsynth-1.7.1-r1.ebuild')
-rw-r--r--media-sound/amsynth/amsynth-1.7.1-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/amsynth/amsynth-1.7.1-r1.ebuild b/media-sound/amsynth/amsynth-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..69a0cb904ff9
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.7.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/nixxcode/amsynth/"
+SRC_URI="https://github.com/nixxcode/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1:= )
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}